[CentOS] Inquiry:yum?

John R Pierce pierce at hogranch.com
Thu Dec 24 06:56:05 UTC 2009


hadi motamedi wrote:
> I tried for the other engaged rpm packages one-by-one . But at last , 
> only the following one remained as unresolved :
> [root at mss-1 tmp]# rpm -Uvh 
> yum-fastestmirror-1.1.16-13.el5.centos.noarch.rpm
> warning: yum-fastestmirror-1.1.16-13.el5.centos.noarch.rpm: Header V3 
> DSA signature: NOKEY, key ID e8562897
> error: Failed dependencies:
>         yum >= 3.0 is needed by 
> yum-fastestmirror-1.1.16-13.el5.centos.noarch
> Can you please let me know why it does not come to an end ?

Try installing both at once...

    # rpm -Uvh yum-....rpm yum-fastestmirror-xxx.....rpm

and if that still doesn't work, try...

    # rpm -Uvh --nodeps  yum-fastestmirror-xxx.yyy.rpm
    # rpm -Uvh yum-xxx.yyy.....rpm

for whatever xxx-yyy files you got.




More information about the CentOS mailing list