[CentOS] Any idea when we will have updated kmod-drbd82 rpm for the latest kernel?

Amos Shapira amos.shapira at gmail.com
Thu Jan 1 21:14:59 UTC 2009


------- Original message -------
From: Alan Sparks <asparks at doublesparks.net>
Sent: 1.1.'09,  9:01
> How is this statement justified?  The RPM dependencies do not indicate 
this:
> 
> $ rpm -qRp kmod-drbd82-smp-8.2.6-2.2.6.9_78.0.5.plus.c4.x86_64.rpm
> /bin/sh
> /bin/sh
> /sbin/depmod
> /sbin/depmod
> drbd82 >= 8.2.6
> kernel-smp-x86_64 = 2.6.9-78.0.5.plus.c4
> rpmlib(CompressedFileNames) <= 3.0.4-1
> rpmlib(PayloadFilesHavePrefix) <= 4.0-1
> rpmlib(VersionedDependencies) <= 3.0.3-1
> 
> $ rpm -qlp kmod-drbd82-smp-8.2.6-2.2.6.9_78.0.5.plus.c4.x86_64.rpm
> /lib/modules/2.6.9-78.0.5.plus.c4smp/extra/drbd.ko
> 
> Since the current kernel is 78.0.8, this module will fail dependency
> checks.  And install to the wrong module directory for the 78.0.8 kernel
> anyway... I have tickets 3291 and 3316 open for this.

For what it's worth, I upgraded from pre-drbd82 to drbd82 by simply 
removing drbd (and assocaited kernel module). I have the exact steps 
documented somewhere if you are interested.

-Amos



More information about the CentOS mailing list