[CentOS] (Semi-OT) Problems with Firefox

Robert kerplop at sbcglobal.net
Mon Jan 12 20:27:41 UTC 2009



Lanny Marcus wrote:
> On Mon, Jan 12, 2009 at 1:55 PM, Sam Drinkard <sam at wa4phy.net> wrote:
>   
>>    After I think the last or next to last update to firefox, I >started
>> seeing some problems, wherein I no longer have a >"back" function on any
>> pages or tabs.
>>     
>
> I am running Firefox on CentOS 5.2 (32 bit) (fully updated) and I am
> not seeing that problem.
>
>   
>>  Also, I get some kind of strange message....
>>
>>  "Assertion Failed ASSERT:***Search:_installLocation: engine has no
>> file! Stack Trace: 0 ENSURE_WARN(false,_installLocation: engine has no
>> file!.2147500037)
>> 1:()2:()3:()4:90:epsGetAttr([objectObject],hidden)5:906:907:currentEngine()
>> 8:get_currentEngine()9:updateDisplay() 10:init() 11:([object XULElement],0)
>>     
>
> Strange messages. I've never seen those.
>   
>>    I realize this is not the proper place for FF related >problems, but
>>     
>
> If you got FF from CentOS I think it's OK to begin here.
>
>   
>> thought I'd ask if someone else has seen something like this happen.
>> Prior to the last 2 updates, FF appeared to be working properly, and all
>> the forward/back buttons worked.
>>     
>
> Can you verify the Firefox Package, to see that it is or is not corrupted?
>   
My Firefox is running just fine, too, Lanny. Seems like I recall the 
O.P. having problems with cross-pollinated repositories some time ago. A 
Firefox update history might be helpful:

    [root at mavis log]# grep -i firefox* /var/log/yum.log.2
    Jun 27 20:27:40 Updated: firefox.i386 1.5.0.12-1.el5.centos
    Jul 20 12:05:52 Updated: firefox.i386 1.5.0.12-3.el5.centos
    Oct 24 07:30:46 Updated: firefox.i386 1.5.0.12-6.el5.centos
    Dec 05 09:39:13 Updated: firefox.i386 1.5.0.12-7.el5.centos
    [root at mavis log]# grep -i firefox\* /var/log/yum.log.2
    Jun 27 20:27:40 Updated: firefox.i386 1.5.0.12-1.el5.centos
    Jul 20 12:05:52 Updated: firefox.i386 1.5.0.12-3.el5.centos
    Oct 24 07:30:46 Updated: firefox.i386 1.5.0.12-6.el5.centos
    Dec 05 09:39:13 Updated: firefox.i386 1.5.0.12-7.el5.centos
    [root at mavis log]# grep -i firefox\* /var/log/yum.log.1
    Feb 10 07:48:31 Updated: firefox.i386 1.5.0.12-9.el5.centos
    Mar 28 08:12:17 Updated: firefox.i386 1.5.0.12-14.el5.centos
    Apr 19 11:19:13 Updated: firefox.i386 1.5.0.12-15.el5.centos
    Jun 24 16:53:06 Updated: firefox.i386 3.0-0.beta5.6.el5.centos
    [root at mavis log]#

Also, it might be useful to remove all addons -- extensions, themes, 
plugins, etc. to see if one of those is causing a problem.


More information about the CentOS mailing list