[CentOS] RHEL 5.3 released

Craig White craigwhite at azapple.com
Wed Jan 21 21:19:29 UTC 2009


On Tue, 2009-01-20 at 23:40 +0200, Pasi Kärkkäinen wrote:
> Hello list!
> 
> http://www.redhat.com/about/news/prarchive/2009/rhel_5_3.html
> 
----
gee...when is it going to be ready?  ;-)

seriously though, found this little tidbit which seems important to note
(under known issues)...

http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5/html/Release_Notes/sect-Release_Notes-Known_Issues.html

When upgrading from an earlier version of Red Hat Enterprise Linux to
5.3, you may encounter the following error: 
Updating  : mypackage                 ################### [ 472/1655]
rpmdb: unable to lock mutex: Invalid argument

The cause of the locking issue is that the shared futex locking in glibc
was enhanced with per-process futexes between 5.2 and 5.3. As a result,
programs running against the 5.2 glibc can not properly perform shared
futex locking against programs running with the 5.3 glibc.

This particular error message is a side effect of a package calling rpm
as part of its install scripts. The rpm instance performing the upgrade
is using the prior glibc throughout the upgrade, but the rpm instance
launched from within the script is using the new glibc. 

To avoid this error, upgrade glibc first in a separate run: 
# yum update glibc
# yum update
You will also see this error if you downgrade glibc to an earlier
version on an installed 5.3 system. 

Craig



More information about the CentOS mailing list