[CentOS] Problem compiling cairo-dock under CentOS 5.2

Filipe Brandenburger filbranden at gmail.com
Mon Jan 26 00:05:52 UTC 2009


Hi,

On Sun, Jan 25, 2009 at 17:14, Marko Vojinovic <vvmarko at panet.co.yu> wrote:
> * update glib2 and possibly glibc and its dependencies?

Bad idea. If you do that, what you will have at the end will no longer
be CentOS, and if you break it, you got to keep the pieces.

> * temper with the cairo-dock source to remove references to new functions and
> make it compatible with glib2 v2.12 (this is possible, but not easy)?

Agreed, possible, but I think it's going to be really hard.

> * wait for CentOS 5.3 hoping that it has more recent glib2?

CentOS 5.3 (or any other 5.x) should not introduce any major upgrades
to glibc or glib2, although minor updates with mainly bug fixes are
expected, it should not bump to another version just like that.

> * give up?

Or try it under Fedora. If you want cutting-edge software, that is
what you should be looking for anyway.

Or yet, you could try to get version 1.x of cairo-dock to build under
CentOS, as that one is more likely to be built than the newer 2.x.

HTH,
Filipe


More information about the CentOS mailing list