[CentOS] Missing latest kmod-xfs and kmod-drbd82?

Alan Sparks asparks at doublesparks.net
Wed Jan 28 02:32:04 UTC 2009


Since December there have been several kernel updates to the centosplus
repository for centos4... but no updates to kmod-xfs or kmod-drbd82. 
Latest kernel is 2.6.9-78.0.13.plus.c4, but latest kmod-xfs is
2.6.9_78.0.5.plus.c4.  Latest drbd82 kmod is also for 78.0.5.

I know there was a mention on the list that these modules are not kernel
dependent anymore... but yum and rpm seem to indicate otherwise, and
trying to install kmod-xfs-smp or update kmod-drbd82-smp on my servers
is not possible.

$ rpm -qRp kmod-xfs-smp-0.4-1.el4.2.6.9_78.0.5.plus.c4.x86_64.rpm
/bin/sh
/bin/sh
/sbin/depmod
/sbin/depmod
kernel-smp-x86_64 = 2.6.9-78.0.5.plus.c4
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(VersionedDependencies) <= 3.0.3-1

Above, the last available version of the module shows a dependency on
the 78.0.5 kernel.  These modules will of course also install in the
wrong /lib/modules/ location.

I've over the last two months opened tickets on bugs.centos.org on the
issue (tickets 3360, 3316, 3291).  However, these tickets are still new
and have had no comments.

Anyone have any advice on dealing with the missing RPMs or the
dependency issue?  Thanks in advance.
-Alan




More information about the CentOS mailing list