[CentOS] liblber-2.3.so.0 is needed by (installed ) ............ on cent os 5.2

Agnello George agnello.dsouza at gmail.com
Mon Mar 2 12:44:55 UTC 2009


Hi

I am trying to upgrde  out openldap ver 2.3  to the lastest version
2.4, howevre there is no rpm avaibale for 2.4 so i decide to create my
own for centOS flavour 5.2

here is the  part look of my spec file openldap.spec

Summary: openldap Installer
Name: openldap
Version: 2.4
Release: 1
Vendor: net Solutions
License: Commercial
Group: ms6
BuildRoot: /usr/src/redhat/BUILD/openldap
Provides: openldap
AutoReq: no
AutoReqProv: no



%description
This package contains the F-PROT Antivirus for Linux.


%files

/bin/
/bin/ldapexop
/bin/ldapmodify
/bin/ldappasswd
/bin/ldapadd
/bin/ldapmodrdn
/bin/ldapdelete
/bin/ldapsearch
/bin/ldapcompare
/bin/ldapwhoami
/etc/openldap/
/etc/openldap/ldap.conf.default
/etc/openldap/ldap.conf
/usr/include/
/usr/include/lber_types.h
/usr/include/ldap_schema.h
/usr/include/ldap_features.h
/usr/include/ldap_cdefs.h
/usr/include/lber.h
/usr/include/ldap.h
/usr/include/slapi-plugin.h
/usr/include/ldap_utf8.h
/lib/
/lib/liblber-2.4.so.2
/lib/liblber.la
/lib/libldap_r-2.4.so.2.1.0
/lib/libldap_r-2.4.so.2
/lib/libldap_r.so
/lib/libldap_r.a
/lib/libldap_r.la
/lib/liblber.so
/lib/liblber.a
/lib/libldap.so
/lib/libldap-2.4.so.2
/lib/liblber-2.4.so.2.1.0
/lib/libldap.a
/lib/libldap-2.4.so.2.1.0
/lib/libldap.la
.

.

/usr/share/man/man5/slapd-sock.5
/usr/share/man/man5/slapd.access.5
/usr/share/man/man5/slapd-relay.5
/usr/share/man/man5/slapd-meta.5
/usr/share/man/man5/slapo-syncprov.5
/usr/share/man/man5/slapd-hdb.5
/usr/share/man/man5/slapo-rwm.5
/usr/share/man/man5/slapd.plugin.5
/usr/share/man/man5/ldif.5
/usr/share/man/man5/slapd-monitor.5
/usr/share/man/man5/slapd-perl.5
%defattr(-, root, root)

%post
cd /lib
ln -s libldap_r-2.4.so.2 libldap_r-2.4.so.2.1.0
ln -s libldap_r.so libldap_r-2.4.so.2.1.0
ln -s liblber.so liblber-2.4.so.2.1.0
ln -s libldap.so libldap-2.4.so.2.1.0
ln -s libldap-2.4.so.2 libldap-2.4.so.2.1.0

it runs perfecetly and creates the RPM for me in
/usr/src/redhat/RPMS/i386/openldap-2.4-1.i386.rpm

however when i try  to upgards the rpm it give me dependencies ....

[root at pune openldap]# rpm -Uvh /usr/src/redhat/RPMS/i386/openldap-2.4-1.i386.rpm
error: Failed dependencies:
  liblber-2.3.so.0 is needed by (installed) apr-util-1.2.7-6.i386
  liblber-2.3.so.0 is needed by (installed) openldap-devel-2.3.27-5.i386
  liblber-2.3.so.0 is needed by (installed) httpd-2.2.3-6.el5.centos.1.i386
  liblber-2.3.so.0 is needed by (installed) cyrus-sasl-2.1.22-4.i386
  liblber-2.3.so.0 is needed by (installed) nss_ldap-253-3.i386
  liblber-2.3.so.0 is needed by (installed) php-ldap-5.1.6-5.el5.i386
  liblber-2.3.so.0 is needed by (installed) openldap-clients-2.3.27-5.i386
  liblber-2.3.so.0 is needed by (installed)
postfix-2.5.5-1.cdb.pcre.sasl2.spf.rhel5.i386
  liblber-2.3.so.0 is needed by (installed) cyrus-imapd-2.3.13-4.i386
  liblber-2.3.so.0 is needed by (installed) mod_perl-2.0.2-6.1.i386
  liblber-2.3.so.0 is needed by (installed) squid-2.6.STABLE6-4.i386
  libldap-2.3.so.0 is needed by (installed) libuser-0.54.7-2.el5.1.i386
  libldap-2.3.so.0 is needed by (installed) apr-util-1.2.7-6.i386
  libldap-2.3.so.0 is needed by (installed) openldap-devel-2.3.27-5.i386
  libldap-2.3.so.0 is needed by (installed) httpd-2.2.3-6.el5.centos.1.i386
  libldap-2.3.so.0 is needed by (installed) cyrus-sasl-2.1.22-4.i386
  libldap-2.3.so.0 is needed by (installed) sudo-1.6.8p12-10.i386

 these modules are already present in the  lib directory
.........../lib/liblber-2.3.so.0 .............

Can some one help me with this error

Thnsk a million

-

Regards
Agnello D'souza


More information about the CentOS mailing list