[CentOS] liblber-2.3.so.0 is needed by (installed ) ............ on cent os 5.2

Jim Perrin jperrin at gmail.com
Mon Mar 2 13:47:33 UTC 2009


On Mon, Mar 2, 2009 at 7:44 AM, Agnello George <agnello.dsouza at gmail.com> wrote:
> Hi
>
> I am trying to upgrde  out openldap ver 2.3  to the lastest version
> 2.4, howevre there is no rpm avaibale for 2.4 so i decide to create my
> own for centOS flavour 5.2


It's probably worth mentioning that the openldap version shipped with
centos is very heavily linked throughout the distribution. If you
upgrade the ldap version, you may have to provide older libraries for
backwards compatibility (as the base package does) or you'll have to
rebuild everything built against openldap against your new version.

On a side note (and while I understand it's just a spec file) you
can't really take the openldap package and strip the openldap license
from it unless their license allows this (I don't believe it does).
You'd have to add your commercial bits in a separate package which
plugs into the openldap framework.


-- 
During times of universal deceit, telling the truth becomes a revolutionary act.
George Orwell


More information about the CentOS mailing list