[CentOS] head scratcher update

Craig White craigwhite at azapple.com
Thu Mar 5 01:59:19 UTC 2009


On Wed, 2009-03-04 at 10:42 -0700, Craig White wrote:
> perhaps my mind isn't working today.
> 
> I'm trying to update a system that hasn't been updated in a while which
> I believe is CentOS 5.2 but it's possible that it's 5.1. I am pretty
> sure that it has php installed from CentOS-Extras and when I do yum
> update, it's stumbling on php
> 
> --> Finished Dependency Resolution
> Error: Missing Dependency: php-common = 5.1.6-20.el5_2.1 is needed by
> package php-mysql
> Error: Missing Dependency: php-common = 5.1.6-20.el5_2.1 is needed by
> package php-cli
> Error: Missing Dependency: php-common = 5.1.6-20.el5_2.1 is needed by
> package php
> Error: Missing Dependency: php-common = 5.1.6-20.el5_2.1 is needed by
> package php-xml
> Error: Missing Dependency: php-common = 5.1.6-20.el5_2.1 is needed by
> package php-ldap
> Error: Missing Dependency: php-common = 5.1.6-20.el5_2.1 is needed by
> package php-imap
> Error: Missing Dependency: php-common = 5.1.6-20.el5_2.1 is needed by
> package php-mbstring
> Error: Missing Dependency: php-common = 5.1.6-20.el5_2.1 is needed by
> package php-pdo
> 
> So I queried rpm to see what's installed...
> # rpm -qa|grep php
> php-common-5.1.6-15.el5
> php-mysql-5.1.6-15.el5
> php-pear-Net-Sieve-1.1.5-2.el5.centos
> php-mcrypt-5.1.6-15.el5.centos.1
> php-pear-MDB2-2.4.1-2.el5.centos
> php-cli-5.1.6-15.el5
> php-5.1.6-15.el5
> php-pear-Net-SMTP-1.2.10-1.el5.centos
> php-pear-Date-1.4.7-2.el5.centos
> php-pear-HTTP-Request-1.4.2-1.el5.centos
> php-pear-1.4.9-4
> php-pear-Mail-Mime-1.4.0-1.el5.centos
> php-xml-5.1.6-15.el5
> php-pecl-memcache-2.2.1-1.el5.centos
> php-pdo-5.1.6-15.el5
> php-pear-Net-Socket-1.0.8-1.el5.centos
> php-pear-Mail-1.1.14-1.el5.centos
> php-pear-Net-URL-1.0.15-1.el5.centos
> php-pear-File-1.2.2-1.el5.centos
> php-pecl-Fileinfo-1.0.4-3.el5.centos
> php-pear-DB-1.7.13-1.el5.centos
> php-ldap-5.1.6-15.el5
> php-pear-Auth-SASL-1.0.2-4.el5.centos
> php-mbstring-5.1.6-15.el5
> php-imap-5.1.6-15.el5
> php-pear-Log-1.9.13-1.el5.centos
> 
> and I suppose I could yum remove php and reinstall but that seems rather
> drastic, plus, I have horde, etc setup too.
> 
> Any suggestions?
----
replying to myself here...

apparently in checking packages one by one, php-mcrypt is required by
the Horde packages but is not part of the upstream php packages and so
it's an issue but there wasn't any warning about that. So removing it
would dependencies should have allowed it to update but it still balked
so I downloaded the various php packages from updates and did a yum
localinstall which did indeed work and now I'm out a php-mcrypt package
(probably not the most important thing anyway).

yum update does seem to pass the initial test and it's presently
downloading packages so I've got my fingers crossed.

Obviously 'extras' is a far lower priority than getting out 5.3

Craig



More information about the CentOS mailing list