[CentOS] epel-5.2 trying to upgrade to 5.3

Ray Van Dolson rayvd at bludgeon.org
Fri Mar 6 15:30:09 UTC 2009


On Fri, Mar 06, 2009 at 10:26:54AM -0500, Lanny Marcus wrote:
> On 3/6/09, Marcelo M. Garcia <marcelo.maia.garcia at googlemail.com> wrote:
> > I just installed CentOS 5.2 (x86_64), and everything was fine. After
> > installing the "epel-release-5-2.noarch.rpm", and issuing "yum
> > check-update", I can see that "epel" is trying to upgrade to version 5.3.
> >
> > First I didn't notice the problem, and after upgrading, I got the
> > message "error sumary" when updating the system.
> >
> > It seems that the x86 (32bit) version is working fine.
> 
> Do you have the yum priorities plug in installed? If not, you should
> install it and I suggest you give EPEL a very low priority, to protect
> your system. I installed the EPEL repository a week or two ago and the
> number of packages being protected on my 32 bit CentOS 5.2 Desktop
> went from approximately 350 to approximately 1600.
> <http://wiki.centos.org/PackageManagement/Yum/Priorities>

While it's certainly a good idea to use yum-priorities, EPEL policy is
such that its repository does not (should not) contain packages that
conflict with base OS packages.

This can obviously change a bit as upstream adds packages between minor
version releases that conflict with EPEL packages.

Ray


More information about the CentOS mailing list