[CentOS] Cannot get CentOS to install

Scott Silva ssilva at sgvwater.com
Wed Mar 11 22:03:57 UTC 2009


on 3-11-2009 1:44 PM Michael Peterson spake the following:
> William L. Maltby wrote:
>> On Tue, 2009-03-10 at 16:37 -0500, Michael Peterson wrote:
>>   
>>> I used google but did not come up with anything current to solve my problem.
>>> I have not tried any other search engines yet.
>>> There is not a search for the CentOS list so I am creating a new post.
>>>     
>> See below - it's really hard to find.
>>
>>   
>>> I have tested the CentOS 5.2 and RHEL 5.3 CD's and they passed.
>>> I had to use linux mediacheck ide=nodma to get them to pass.
>>> The newest releases seem to most times fail with just linux mediacheck.
>>>     
>> Try making the media after padding the iso image with about 300k of
>> zeros. When you search the archives (there is a search - I'll mention
>> below) there are a couple of threads about this.
>>
>>   
>>> I have tried linux ide=nodma and
>>> linux text ide=nodma after trying
>>> linux and
>>> linux text
>>>
>>> Anaconda fails on both CentOS 5.2 and RHEL 5.3 in all cases.
>>>     
>> With only 512MB or ram you will have to use text mode only, IIRC. Also
>> in the archives. There's also some threads that mention noacpi, acpi=no
>> and some other stuff I can't recall.
>>
>>   
>>> The system I am trying to install on is running CentOS 3.x.
>>>
>>> The hardware is P4 2.8 CPU, 512 MB RAM, 120GB 3ware IDE/PATA RAID HD, 
>>> ATI Video, CDRW CD, Dual Nic, Floppy and IDE/PATA Tape drive.
>>>
>>> Please provide any options to the kernel that I should try besides the 
>>> ones mentioned above that fail.
>>> <snip>
>>>     
>> For your google searches, go to the advanced section and specify
>> centos.org. That gets what's in the archives. To search directly from
>> CentOS site, click "Search" on http://centos.org/
>>
>> HTH,
>>   
> The system I am trying to install on boot with out problems or errors on 
> the 5.2 Live CD.
> Gui works
> Firefox and Network work
> 
> I tried the options mentioned and more and get the same errors.
> They are:
> 
> Starting graphical installation ...
> Traceback (most recent call last):
> File "/usr/bin/anaconda", line 900, in ? iutil.makeDriveDeviceNodes()
> File "/usr/lib/anaconda/iutil.py". line 264, in makeDriveDeviceNodes
> isys.makeDevinode(device, "dev /%s" % (device,))
> File "/usr/lib/anaconda.isys.py", line 422, inmakeDevInode 
> _isys.mkdevinode(name,fn)
> SystemError: (2, 'No such file or directory')
> install exited abnormally [1/1]
> sending termination signals ... done
> 
> 
> The RHEL 5.3 boot disk is the same as above except the line 900 is 924.
> 
> I have tried text and GUI and ide=nodma pci=noacpi with both.
Can you see and write to the hard disks with the Live CD?



-- 
MailScanner is like deodorant...
You hope everybody uses it, and
you notice quickly if they don't!!!!

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 258 bytes
Desc: OpenPGP digital signature
Url : http://lists.centos.org/pipermail/centos/attachments/20090311/6e4e8857/attachment.bin 


More information about the CentOS mailing list