[CentOS] Getting "poll: protocol failure in circuit setup" from rsh - solved

Sorin Srbu sorin.srbu at orgfarm.uu.se
Thu Mar 12 14:46:42 UTC 2009


>-----Original Message-----
>From: centos-bounces at centos.org [mailto:centos-bounces at centos.org] On
Behalf
>Of Sorin Srbu
>Sent: Friday, February 20, 2009 11:36 AM
>To: 'CentOS mailing list'
>Subject: [CentOS] Getting "poll: protocol failure in circuit setup" from
rsh
>
> I inherited a cpu-stats script from the previous *nixadmin at our
> department. This script relies on a rsh-command to get the vmstats from
the
> remote machines and then using a perl script to push it to a web server.
>
>Now I've just added a new machine running CentOS 5.2 x64 to the script and
I
>get the error message in the subject line; "poll: protocol failure in
>circuit setup".

Replying on my own post for archival reasons:
The error was in /etc/hosts.allow. I forgot to add a line "in.rshd: FQDN" in
hosts.allow on the machine I imaged and then used to install to a bunch of
other machines. Easy to miss though, there are a dozen or so other lines in
there allowing other daemons and stuff.

Fixing that, now "rsh remote-machine vmstat" works as expected.
-- 
/Sorin

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 5106 bytes
Desc: not available
Url : http://lists.centos.org/pipermail/centos/attachments/20090312/64f3dd9d/attachment.bin 


More information about the CentOS mailing list