[CentOS] grub issue

David G. Miller dave at davenjudy.org
Mon Mar 16 19:39:36 UTC 2009


Indunil Jayasooriya <indunil75 at gmail.com> wrote:

> Pls see below
>
>
> [root at authpassword ~]# cat /boot/grub/grub.conf
> # grub.conf generated by anaconda
> #
> # Note that you do not have to rerun grub after making changes to this file
> # NOTICE:  You have a /boot partition.  This means that
> #          all kernel and initrd paths are relative to /boot/, eg.
> #          root (hd2,0)
> #          kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
> #          initrd /initrd-version.img
> #boot=/dev/sdb
> default=0
> timeout=5
> splashimage=(hd2,0)/grub/splash.xpm.gz
> hiddenmenu
> title Red Hat Enterprise Linux Server (2.6.18-128.1.1.el5PAE)
>         root (hd2,0)
>         kernel /vmlinuz-2.6.18-128.1.1.el5PAE ro
> root=/dev/VolGroup00/LogVol00 rhgb quiet
>         initrd /initrd-2.6.18-128.1.1.el5PAE.img
> title Red Hat Enterprise Linux Server (2.6.18-92.el5PAE)
>         root (hd2,0)
>         kernel /vmlinuz-2.6.18-92.el5PAE ro
> root=/dev/VolGroup00/LogVol00 rhgb quiet
>         initrd /initrd-2.6.18-92.el5PAE.img
>   
as a follow up to why it was necessary to issue the following command at 
the grub command prompt:
> grub> root (hd0,0)
>  Filesystem type is ext2fs, partition type 0x83
Note that you are telling grub to find the root file system on drive hd0 
and partition 0.  The grub.conf file provided has root set to drive hd2 
and partition 0.  It appears that something changed the order of your 
drive numbering (e.g. you moved the cable that attached you boot drive 
from IDE1 to IDE0 when you installed the new CPU).

Cheers,
Dave

-- 
Politics, n. Strife of interests masquerading as a contest of principles.
-- Ambrose Bierce



More information about the CentOS mailing list