[CentOS] hplip problems - configure: error: "cannot find libjpeg support"

Anne Wilson cannewilson at googlemail.com
Mon Mar 16 21:23:46 UTC 2009


On Monday 16 March 2009 19:30:17 Robert Nichols wrote:
> Anne Wilson wrote:
> > I have hplip running on Mandriva 2009, Fedora 9 and Fedora 10.  I get the
> > full range of services there.  I don't know why we have this strange
> > situation on CentOS.  The HP website says it is tested against CentOS  5,
> > yet the problems seem to be down to not being able to find packages that
> > are definitely installed, and installed by totally standard yum :-(
>
> The usual problem when a build procedure complains that a package is
> missing when you actually have it installed is that you need the
> matching "-devel" package.  The base package just provides the execution
> libraries.  You need the development package in order to build new
> programs that use those libraries.

Yes, I understand that.  I did forget, at the beginning, but that problem was 
resolved a week or more ago.  All the packages that needed -devel packages got 
them installed.  If I had had more time to spend on it, it might have been 
possible to track down why it failed to find the package.  The actuall error 
was

Checking for dependency: DBus - Message bus system...
error: NOT FOUND! This is a REQUIRED dependency. Please make sure that this 
dependency is installed before installing or running HPLIP.

I might have another play with this setup when things are less busy.

Anne
-- 
New to KDE4? - get help from http://userbase.kde.org
Just found a cool new feature?  Add it to UserBase
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part.
Url : http://lists.centos.org/pipermail/centos/attachments/20090316/a583be1e/attachment.bin 


More information about the CentOS mailing list