[CentOS] Installing openmpi & lam for use with R

Tony Schreiner schreian at bc.edu
Fri Mar 27 16:18:16 UTC 2009


On Mar 27, 2009, at 12:08 AM, Rick Bilonick wrote:

> I am trying to install the R package "Rmpi" which needs libmpi. I've
> installed openmpi and lam in Centos 5.2:
>
> [root at rab45-1 /]# rpm -qv openmpi
> openmpi-1.2.5-5.el5
> openmpi-1.2.5-5.el5
> [root at rab45-1 /]# rpm -qv lam
> lam-7.1.2-14.el5
> lam-7.1.2-14.el5
>
> But I get the following error message when trying to install Rmpi:
>
> /usr/bin/ld: skipping incompatible /usr/lib/lam/lib/libmpi.so when
> searching for -lmpi
>
> I'm not sure what else to install/uninstall to fix this.
>
> Rick B.
>

Is Rmpi packaged somehow or are you getting it from CRAN?

The web site http://www.stats.uwo.ca/faculty/yu/Rmpi/ suggests it  
should work with either LAM-MPI or OpenMPI or even MPICH2

Have you installed the mpi-selector RPM and set it up? This will set  
up LD_LIBRARY_PATH to the selected MPI version. But I don't know if it  
will fix your issue.

Tony Schreiner
Boston College


More information about the CentOS mailing list