[CentOS] APCUPSD port 3551 permission problem

Bob Taylor bob8221 at gmail.com
Sun Mar 29 07:24:24 UTC 2009


On Sat, 2009-03-28 at 14:36 -0600, Joseph L. Casale wrote:
> >I need a little help on this problem, please? I include
> >my /etc/apcupsd/apcupsd.conf file is attached.
> 
> Ok
> 
> >port 3551 udp/tcp has
> >been added to the (running) firewall.
> 
> Are you attempting to run the agent on a machine *without*
> the ups comm connected to it, such that it will receive status
> from the server that does have it connected and shutdown when
> that remote agent that *is* monitoring the ups suggests it should?
> 
> I don't think so, I think your ups is connected to the server
> that is running the agent. You need not add this port to the
> firewall. It talks to itself over the loopback adapter.

You're quite correct sir. My misunderstanding on how a firewall and the
computer software may interconnect.

> >My APC is recognized as:
> >APC Back-UPS 450 FW:844.Kld.D USB FW:Kld
> >This from the hardware browser.
> 
> >PS says:
> >root      2419  0.0  0.0   4196   584 ?        Ss   Mar23
> >0:09 /sbin/apcupsd -f /etc/apcupsd/apcupsd.conf
> >
> >Is group 2419 the problem? What should I name it? apcupsd?
> 
> Group? Below your gui correctly identifies that data field as
> the pid:)

My sincere apologies. I know better. I must have been too tired.

> >The status field of the Service Configuration GUI says:
> >apcupsd (pid 2419) is running...
> >Error contacting host localhost port 3551: Connection refused
> 
> You have suggested the NETSERVER directive be off, but you want
> a client side app to communicate with it:) Turn that "on" and
> restart it.

OK. Did that. Now listening on 127.0.0.1:3551 tcp instead of Unix DGRAM.

Thanks for the help!
-- 
Bob Taylor



More information about the CentOS mailing list