[CentOS] Ruby Enterprise Edition

Stephen Nelson-Smith stephen at atalanta-systems.com
Wed Nov 4 22:53:09 UTC 2009


I find myself needing a newer Ruby than is in the distro.  I'm going
to need to install this on a large number of machines, so packaging it
would be ideal.

REE seems the obvious candidate - unless other folk can recommend an
alternative.

I found the following spec:

http://www.cherpec.com/wp-content/uploads/2009/10/ruby-enterprise.spec

In my build environment I get:

$ rpmbuild -tb ruby-enterprise.spec
error: Name field must be present in package: (main package)
error: Version field must be present in package: (main package)
error: Release field must be present in package: (main package)
error: Summary field must be present in package: (main package)
error: Group field must be present in package: (main package)
error: License field must be present in package: (main package)

I've not fixed this yet, but thought I'd ask if anyone else has a spec
or package they can recommend, before I start reinventing wheels.

Thanks,

S.


More information about the CentOS mailing list