[CentOS] screwed up dependencies

ken gebser at mousecar.com
Wed Nov 11 10:17:52 UTC 2009


On 11/11/2009 02:26 AM Timo Schoeler wrote:
> thus ken spake:
> | Subsequent to trying to "yum update"-- it failed--, I tried to resolve
> | the dependencies piecemeal:
> |
> | # yum update faad2
> | ....
> | --> Processing Dependency: libfaad.so.0 for package: ffmpeg
> | ---> Package faad2.i386 0:2.7-1.el5.rf set to be updated
> | --> Finished Dependency Resolution
> | ffmpeg-0.5-2.el5.rf.i386 from installed has depsolving problems
> |   --> Missing Dependency: libfaad.so.0 is needed by package
> | ffmpeg-0.5-2.el5.rf.i386 (installed)
> | Error: Missing Dependency: libfaad.so.0 is needed by package
> | ffmpeg-0.5-2.el5.rf.i386 (installed)
> | ....
> |
> | # rpm -q ffmpeg
> | ffmpeg-0.5-2.el5.rf
> |
> | Could it be that there's a packaging error in faad2 ?
> 
> For the archives: This seems to be fixed; I updated three systems since
> then and everything went flawlessly.
> 
> HTH,
> 
> Timo

Timo,

Thanks for replying.

I found that, ultimately, I had to remove xine* and its dependencies in
order to successfully "yum update".  After the update, I get dependency
errors again (with libdirect-1.0.so.0, libdirectfb-1.0.so.0, and
libfusion-1.0.so.0) when I try to add xine back in.  Are you running
xine on any of your systems?





More information about the CentOS mailing list