[CentOS] screwed up dependencies

fred smith fredex at fcshome.stoneham.ma.us
Wed Nov 11 15:15:09 UTC 2009


On Wed, Nov 11, 2009 at 05:35:52AM -0600, Lee Perez wrote:
> ken wrote:
> > On 11/11/2009 02:26 AM Timo Schoeler wrote:
> >   
> >> thus ken spake:
> >> | Subsequent to trying to "yum update"-- it failed--, I tried to resolve
> >> | the dependencies piecemeal:
> >> |
> >> | # yum update faad2
> >> | ....
> >> | --> Processing Dependency: libfaad.so.0 for package: ffmpeg
> >> | ---> Package faad2.i386 0:2.7-1.el5.rf set to be updated
> >> | --> Finished Dependency Resolution
> >> | ffmpeg-0.5-2.el5.rf.i386 from installed has depsolving problems
> >> |   --> Missing Dependency: libfaad.so.0 is needed by package
> >> | ffmpeg-0.5-2.el5.rf.i386 (installed)
> >> | Error: Missing Dependency: libfaad.so.0 is needed by package
> >> | ffmpeg-0.5-2.el5.rf.i386 (installed)
> >> | ....
> >> |
> >> | # rpm -q ffmpeg
> >> | ffmpeg-0.5-2.el5.rf
> >> |
> >> | Could it be that there's a packaging error in faad2 ?
> >>

I saw the same errors, waited a day or so and they went away, so it must
have been a stale mirror.

> >> For the archives: This seems to be fixed; I updated three systems since
> >> then and everything went flawlessly.
> >>
> >> HTH,
> >>
> >> Timo
> >>     
> >
> > Timo,
> >
> > Thanks for replying.
> >
> > I found that, ultimately, I had to remove xine* and its dependencies in
> > order to successfully "yum update".  After the update, I get dependency
> > errors again (with libdirect-1.0.so.0, libdirectfb-1.0.so.0, and
> > libfusion-1.0.so.0) when I try to add xine back in.  Are you running
> > xine on any of your systems?
> >
> >
> >   
> Hi Ken,
> 
> I'm running 5.4 here on my system and I have xine installed.  I just 
> updated faad2 and everything went fine here.  Here is a list of what was 
> updated:
> 
> Nov 11 05:08:24 Updated: faad2-2.7-1.el5.rf.i386
> Nov 11 05:08:26 Updated: ffmpeg-0.5-3.el5.rf.i386
> Nov 11 05:08:30 Updated: xine-lib-1.1.16.3-2.el5.rf.i386
> Nov 11 05:08:50 Updated: vlc-0.9.9a-4.el5.rf.i386
> 
> Also I went and checked in /usr/lib and the libdirect, libdirectfb, and 
> libfusion version I have installed are:
> 
> libdirect-1.2.so.0      libdirectfb-1.2.so.0
> libdirect-1.2.so.0.4.0  libdirectfb-1.2.so.0.4.0
> libfusion-1.2.so.0  libfusion-1.2.so.0.4.0
> 
> I don't have any other repos setup except for rpmforge and priorities 
> are setup.\
> 
> HTH.
> 
> Lee Perez
-- 
---- Fred Smith -- fredex at fcshome.stoneham.ma.us ------------------------ ----
                    Do you not know? Have you not heard? 
    The LORD is the everlasting God, the Creator of the ends of the earth. 
  He will not grow tired or weary, and his understanding no one can fathom.
----------------------------- Isaiah 40:28 (niv) -----------------------------


More information about the CentOS mailing list