[CentOS] kernel not booting after update

Ross Walker rswwalker at gmail.com
Fri Nov 13 05:22:40 UTC 2009


On Nov 12, 2009, at 7:53 PM, Spiro Harvey <spiro at knossos.net.nz> wrote:

>> I would backup ALL your file systems off that disk, perhaps using a
>
> This is a fresh install, so that's not an issue.
>
>> Linux rescue CD, then configure the controller in the BIOS for JBOD,
>> use a rescue disk to build mdraid partitions, and restore your files
>> from the backups.   you may have to rebuild the /boot/initrd on the
>> system to dump the fakeraid (dmraid) driver and enable the mdraid
>> native linux raid driver
>
> I'm interested in knowing why the machine isn't booting some kernels,
> but will happily boot another. I figure if it's a hardware issue, then
> it should be an all-or-nothing issue? I'm positive this is the same
> spec as the last servers built for this same purpose, but the others
> are now on the other side of the country, so I can't access them to
> verify.
>
> So assuming the hardware is exactly the same, and assuming there's
> something in the -164 kernel that doesn't like that particular fake
> raid card, then I still can't see why I can't boot the -128 kernel as
> that's what the other boxes have running. :/

You might have installed a driver for the fake raid before which added  
it to /etc/modprobe.conf and did a mkinitrd to add it to the initrd  
during boot, but at some point removed it and from that point on newer  
kernels didn't get the driver in their initrd images?

Just an idea.

-Ross



More information about the CentOS mailing list