[CentOS] PHP updates

Craig White craigwhite at azapple.com
Wed Nov 25 21:35:14 UTC 2009


On Wed, 2009-11-25 at 23:22 +0200, Rudi Ahlers wrote:
> On Wed, Nov 25, 2009 at 11:13 PM, Craig White <craigwhite at azapple.com> wrote:
> > For the 2 threads going on about PHP 5.2/5.3...
> >
> > CentOS tracks upstream whose version is...
> > php-5.1.6-23.2.el5_3
> >
> > If you want something newer, you have to go off the beaten path.
> >
> > try this...(as root)
> > wget http://dev.centos.org/centos/5/CentOS-Testing.repo
> > mv CentOS-Testing.repo /etc/yum.repos.d
> > yum --enablerepo=c5-testing check-update
> >
> > and this would allow to update to version 5.2.9-2.el5.centos if you
> > then...
> >
> > yum --enablerepo=c5-testing update php
> >
> > and if enough people actually convinced the developers that
> > 5.2.9-2.el5.centos were feasible, then they would probably move it into
> > the 'Extras' repository.
> >
> > Craig
> >
> >
> > --
> 
> 
> Thanx for sharing this with us. I'm sitting with a similar problem
> right now, and would like to know, how can I install PHP 5.2.10?
----
try downloading the source rpm, swap the php tarball with the one you
want to use, rebuild the rpm from the specfile.

Good luck

Craig


-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.



More information about the CentOS mailing list