[CentOS] GnuPG for CentOS 5.3?

Lanny Marcus lmmailinglists at gmail.com
Sun Oct 4 18:22:08 UTC 2009


On Sun, Oct 4, 2009 at 11:27 AM, Lanny Marcus <lmmailinglists at gmail.com> wrote:
> On Sun, Oct 4, 2009 at 10:21 AM, Johnny Hughes <johnny at centos.org> wrote:
> <snip>
>>>>>>>> If you are using Gnome, you may want to check out seahorse. Very easy to
>>>>>>>> use.
> <snip>
>>>>> Seahorse is Gnome app, and the latest version requires gtk-2.16.x ...
>>>>> CentOS-5.x contains gtk2-2.10.x so I would imagine the latest seahorse
>>>>> will not work with CentOS.
> <snip>
>>
>> This SRPM will build on CentOS-5.x ... IF ... you install gpgme,
>> gpgme-devel, and pth from RPMForge on the build machine (or make them
>> available for mock if you build with that).
>
> Johnny: Also this dependency:
> Installing for dependencies:
>  libgpg-error-devel      i386      1.4-2                    base           17 k
> Now I'll try to get the SRPM for Seahorse on the CentOS web site. Lanny
>
Johnny: I got the SRPM and I tried to rebuild seahorse, but I got a
bunch of build dependencies (see below). Are all of those compatible
with CentOS 5 .3 (32 bit)? If so, I'll get them and try it again.
Also, I am not trying to build as root (which I know is dangerous),
but am getting those warnings user and group mockbuild does not exist
- using root.  Does that mean it is trying to build as root, which is
dangerous? If so, how do I avoid that danger?    TIA!    Lanny

[devel at dell2400 SRPMS]$ rpmbuild --rebuild seahorse-2.20.3-3.src.rpm
Installing seahorse-2.20.3-3.src.rpm
warning: user mockbuild does not exist - using root
warning: group mockbuild does not exist - using root
warning: user mockbuild does not exist - using root
warning: group mockbuild does not exist - using root
warning: user mockbuild does not exist - using root
warning: group mockbuild does not exist - using root
error: Failed build dependencies:
        gedit-devel is needed by seahorse-2.20.3-3.i386
        libgnome-devel is needed by seahorse-2.20.3-3.i386
        libgnomeui-devel is needed by seahorse-2.20.3-3.i386
        nautilus-devel is needed by seahorse-2.20.3-3.i386
        libsoup-devel is needed by seahorse-2.20.3-3.i386
        openldap-devel is needed by seahorse-2.20.3-3.i386
        gnome-panel-devel is needed by seahorse-2.20.3-3.i386
        libnotify-devel is needed by seahorse-2.20.3-3.i386
        perl-XML-Parser is needed by seahorse-2.20.3-3.i386
        gnome-keyring-devel is needed by seahorse-2.20.3-3.i386
        avahi-devel is needed by seahorse-2.20.3-3.i386
        avahi-glib-devel is needed by seahorse-2.20.3-3.i386
        chrpath is needed by seahorse-2.20.3-3.i386
[devel at dell2400 SRPMS]$


More information about the CentOS mailing list