[CentOS] SVN hell!

Guy Boisvert boisvert.guy at videotron.ca
Sun Oct 11 22:41:21 UTC 2009


Hi!

	I'm trying to install SVN on a latest version of CentOS (5.3).  I just did:

yum install subversion
yum install mod_dav_svn


Then i edited /etc/httpd/conf.d/subversion.conf

and here is the content:
========================
<Location /svn>
    DAV svn
    SVNParentPath /var/www/svn

    # Limit write permission to list of valid users.
    <LimitExcept GET PROPFIND OPTIONS REPORT>
       # Require SSL connection for password protection.
       # SSLRequireSSL

       AuthType Basic
       AuthName "SVN 1"
       AuthUserFile /etc/svn/svn-auth-conf
       Require valid-user
    </LimitExcept>
</Location>


After, i did:
=============
mkdir -p //var/www/svn/applitv
svnadmin create /var/www/svn/applitv
svn mkdir file://localhost/var/www/svn/applitv/trunk -m "create"
svn mkdir file://localhost/var/www/svn/applitv/branches -m "create"
svn mkdir file://localhost/var/www/svn/applitv/tags -m "create"
chown -R apache:apache /var/www/svn


Finally, i created the AUTH file:
=================================
htpasswd -cm /etc/svn/svn-auth-conf user1
htpasswd -m /etc/svn/svn-auth-conf user2




I use the following URL to connect to the server:
=================================================
http://10.0.4.32/svn/applitv



And i receive the following response:
=====================================
This XML file does not appear to have any style information associated 
with it. The document tree is shown below.

−
<D:error>
<C:error/>
<m:human-readable errcode="13">
Could not open the requested SVN filesystem
</m:human-readable>
</D:error>


In the log /etc/httpd/conf.d/subversion.conf, i have:
=====================================================
[Sun Oct 11 15:48:39 2009] [error] [client 10.0.2.98] (20014)Internal 
error: Can't open file '/var/www/svn/applitv/format': Permission denied
[Sun Oct 11 15:48:39 2009] [error] [client 10.0.2.98] Could not fetch 
resource information.  [500, #0]
[Sun Oct 11 15:48:39 2009] [error] [client 10.0.2.98] Could not open the 
requested SVN filesystem  [500, #13]
[Sun Oct 11 15:48:39 2009] [error] [client 10.0.2.98] Could not open the 
requested SVN filesystem  [500, #13]
[Sun Oct 11 15:48:39 2009] [error] [client 10.0.2.98] Could not fetch 
resource information.  [403, #0]
[Sun Oct 11 15:48:39 2009] [error] [client 10.0.2.98] (2)No such file or 
directory: The URI does not contain the name of a repository.  [403, 
#190001]


What i find very strange is this:
=================================
[root at svn mnt]# ll /var/www/svn/applitv/format
-r--r--r-- 1 apache apache 2 Oct 11 11:40 /var/www/svn/applitv/format

The "format" file (which contains the value "5") is readable.

I searched a lot on Google but i still can't figure out what's going on. 
  Any help would be appreciated!


MISC INFOS:
===========
[root at svn www]# uname -a
Linux svn.[removed].com 2.6.18-164.el5xen #1 SMP Thu Sep 3 04:47:32 EDT 
2009 i686 athlon i386 GNU/Linux
(Guest running under Xen CentOS X64 Host)

[root at svn www]# cat /etc/issue
CentOS release 5.3 (Final)

httpd-2.2.3-22.el5.centos.2
mod_dav_svn-1.4.2-4.el5_3.1


Thanks!

Guy Boisvert, ing.
IngTegration inc.


More information about the CentOS mailing list