[CentOS] update 5.4 problem using yum

Jens Ahlin mailing_lists+centos at caleotech.com
Fri Oct 23 07:23:32 UTC 2009


Hi,

I have tried to update one of my servers to 5.4. I read the release notes
and ran yum clean all followed by yum update glibc\* without any problem,
I then ran yum update glibc\* which failed.

Resolving Dependencies
--> Running transaction check
---> Package python-devel.i386 0:2.4.3-27.el5 set to be updated
---> Package rpm-libs.i386 0:4.4.2.3-18.el5 set to be updated
--> Processing Dependency: popt = 1.10.2.3-18.el5 for package: rpm-libs
---> Package python.i386 0:2.4.3-27.el5 set to be updated
---> Package yum-metadata-parser.i386 0:1.1.2-3.el5.centos set to be updated
---> Package rpm-python.i386 0:4.4.2.3-18.el5 set to be updated
---> Package rpm-devel.i386 0:4.4.2.3-18.el5 set to be updated
---> Package yum.noarch 0:3.2.22-20.el5.centos set to be updated
---> Package rpm.i386 0:4.4.2.3-18.el5 set to be updated
---> Package rpm-build.i386 0:4.4.2.3-18.el5 set to be updated
--> Running transaction check
---> Package popt.i386 0:1.10.2.3-18.el5 set to be updated
*** glibc detected *** /usr/bin/python: free(): invalid pointer:
0x0a98d660 ***
*** glibc detected *** /usr/bin/python: double free or corruption (out):
0x092e04c8 ***

Now I cannot run yum or rpm to restore the updated glibc packages. Any
idea's ? Did I miss something ?

      Jens


More information about the CentOS mailing list