[CentOS] can't "yum install mplayer" : no libmpcdec.so.3 available

Majian jiannma at gmail.com
Fri Oct 23 13:34:05 UTC 2009


Have a try  the rpmforge repo to install mplayer ~~~

O n Fri, Oct 23, 2009 at 8:23 PM, ken <gebser at mousecar.com> wrote:

> Just upgraded to 5.4 yesterday morning.  (Kudos to those who did that!)
> That's probably irrelevant to this problem:
>
> "yum install mplayer" fails.  Here's what happens:
>
> ==================================================
>  # yum install mplayer
> Loaded plugins: fastestmirror, filter-data, kernel-module, keys, kmod,
> list-
>              : data, merge-conf, security, upgrade-helper, verify,
> versionlock
> Loading mirror speeds from cached hostfile
>  * addons: mirrors.serveraxis.net
>  * base: mirror.anl.gov
>  * centosplus: mirror.atlanticmetro.net
>  * contrib: updates.interworx.info
>  * epel: mirrors.dmacc.net
>  * extras: mirrors.serveraxis.net
>  * updates: mirrors.rit.edu
> Skipping filters plugin, no data
> Reading version lock configuration
> Setting up Install Process
> Resolving Dependencies
> Skipping filters plugin, no data
> --> Running transaction check
> ---> Package mplayer.i386 0:1.0-0.34.rc1try2.fc6 set to be updated
> --> Processing Dependency: liblirc_client.so.0 for package: mplayer
> --> Processing Dependency: mplayer-fonts for package: mplayer
> --> Processing Dependency: libaudio.so.2 for package: mplayer
> --> Processing Dependency: libmpcdec.so.3 for package: mplayer
> --> Running transaction check
> ---> Package mplayer.i386 0:1.0-0.34.rc1try2.fc6 set to be updated
> --> Processing Dependency: liblirc_client.so.0 for package: mplayer
> --> Processing Dependency: libmpcdec.so.3 for package: mplayer
> ---> Package mplayer-fonts.noarch 0:1.1-3.fc set to be updated
> ---> Package nas.i386 0:1.9.1-2.el5 set to be updated
> --> Finished Dependency Resolution
> mplayer-1.0-0.34.rc1try2.fc6.i386 from freshrpms has depsolving problems
>  --> Missing Dependency: liblirc_client.so.0 is needed by package
> mplayer-1.0-0.34.rc1try2.fc6.i386 (freshrpms)
> mplayer-1.0-0.34.rc1try2.fc6.i386 from freshrpms has depsolving problems
>  --> Missing Dependency: libmpcdec.so.3 is needed by package
> mplayer-1.0-0.34.rc1try2.fc6.i386 (freshrpms)
> Error: Missing Dependency: liblirc_client.so.0 is needed by package
> mplayer-1.0-0.34.rc1try2.fc6.i386 (freshrpms)
> Error: Missing Dependency: libmpcdec.so.3 is needed by package
> mplayer-1.0-0.34.rc1try2.fc6.i386 (freshrpms)
>  You could try using --skip-broken to work around the problem
>  You could try running: package-cleanup --problems
>                        package-cleanup --dupes
>                        rpm -Va --nofiles --nodigest
> ==================================================
>
> Yep, I did run"
>
> # package-cleanup --dupes
> Setting up yum
> giflib-4.1.3-7.1.el5.1.i386
> giflib-4.1.3-7.1.el5_3.1.i386
> # rpm -qa |grep giflib
> giflib-4.1.3-7.1.el5.1
> giflib-4.1.3-7.1.el5_3.1
> giflib-devel-4.1.3-7.1.el5_3.1
>
> so erased giflib-4.1.3-7.1.el5.1.i386, but still got the same from yum
>
>
> ==================================================
> # package-cleanup --problems
> Setting up yum
> Reading local RPM database
> Processing all local requires
> No problems found
> ==================================================
>
> Maybe removing the above dupes fixed it???  Nope, "yum install mplayer"
> still flipped me an error.  So then tried:
>
> ==================================================
> # yum install --skip-broken mplayer
> Loaded plugins: fastestmirror, filter-data, kernel-module, keys, kmod,
> list-
>              : data, merge-conf, security, upgrade-helper, verify,
> versionlock
> Loading mirror speeds from cached hostfile
>  * addons: mirrors.serveraxis.net
>  * base: mirror.anl.gov
>  * centosplus: mirror.atlanticmetro.net
>  * contrib: updates.interworx.info
>  * epel: mirrors.dmacc.net
>  * extras: mirrors.serveraxis.net
>  * updates: mirrors.rit.edu
> Skipping filters plugin, no data
> Reading version lock configuration
> Setting up Install Process
> Resolving Dependencies
> Skipping filters plugin, no data
> --> Running transaction check
> ---> Package mplayer.i386 0:1.0-0.34.rc1try2.fc6 set to be updated
> --> Processing Dependency: liblirc_client.so.0 for package: mplayer
> --> Processing Dependency: mplayer-fonts for package: mplayer
> --> Processing Dependency: libaudio.so.2 for package: mplayer
> --> Processing Dependency: libmpcdec.so.3 for package: mplayer
> --> Running transaction check
> ---> Package mplayer.i386 0:1.0-0.34.rc1try2.fc6 set to be updated
> --> Processing Dependency: liblirc_client.so.0 for package: mplayer
> --> Processing Dependency: libmpcdec.so.3 for package: mplayer
> ---> Package mplayer-fonts.noarch 0:1.1-3.fc set to be updated
> ---> Package nas.i386 0:1.9.1-2.el5 set to be updated
> --> Finished Dependency Resolution
> mplayer-1.0-0.34.rc1try2.fc6.i386 from freshrpms has depsolving problems
>  --> Missing Dependency: liblirc_client.so.0 is needed by package
> mplayer-1.0-0.34.rc1try2.fc6.i386 (freshrpms)
> mplayer-1.0-0.34.rc1try2.fc6.i386 from freshrpms has depsolving problems
>  --> Missing Dependency: libmpcdec.so.3 is needed by package
> mplayer-1.0-0.34.rc1try2.fc6.i386 (freshrpms)
>
> Packages skipped because of dependency problems:
>    mplayer-1.0-0.34.rc1try2.fc6.i386 from freshrpms
>    mplayer-fonts-1.1-3.fc.noarch from freshrpms
>    nas-1.9.1-2.el5.i386 from epel
> ==================================================
>
> This looks like it might be the cause:
>
> # rpm -ql libmpcdec
> /usr/lib/libmpcdec.so.5
> /usr/lib/libmpcdec.so.5.0.2
> /usr/share/doc/libmpcdec-1.2.6
> ... <snip> ...
>
> i.e., the dependency is already installed, but the installed version is
> higher than what's requested... or the dependency is misspecified
> (libmpcdec.so.3)...(?)
>
> and/or liblirc/liblirc_client and libaudio aren't available (at least in
> the repos my yum is set up for.
>
>
> What to do.. what to do??
>
>
> --
> War is a failure of the imagination.
>        --William Blake
>
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.centos.org/pipermail/centos/attachments/20091023/f7225485/attachment.html 


More information about the CentOS mailing list