[CentOS] Upgrading CentOS 5.3 to 5.4 errors

Rohan Gilchrist rohan at gilchrist.me
Sat Oct 24 22:09:32 UTC 2009


Hello,

I thought I'd wait a little while before upgrading to 5.4, but am 
running into the following errors:

-> Finished Dependency Resolution
lvm2-2.02.46-8.el5.i386 from base has depsolving problems
  --> Missing Dependency: device-mapper >= 1.02.32-1 is needed by 
package lvm2-2.02.46-8.el5.i386 (base)
mkinitrd-5.1.19.6-54.i386 from base has depsolving problems
  --> Missing Dependency: device-mapper-multipath >= 0.4.7-9 is needed 
by package mkinitrd-5.1.19.6-54.i386 (base)
lvm2-2.02.46-8.el5.i386 from base has depsolving problems
  --> Missing Dependency: device-mapper-event is needed by package 
lvm2-2.02.46-8.el5.i386 (base)
Error: Missing Dependency: device-mapper-multipath >= 0.4.7-9 is needed 
by package mkinitrd-5.1.19.6-54.i386 (base)
Error: Missing Dependency: device-mapper-event is needed by package 
lvm2-2.02.46-8.el5.i386 (base)
Error: Missing Dependency: device-mapper >= 1.02.32-1 is needed by 
package lvm2-2.02.46-8.el5.i386 (base)

It would appear that these packages do exist, although earlier versions:

# rpm -q device-mapper
device-mapper-1.02.13-1.el5

Any thoughts would be appreaicated.

Regards,

Rohan.



-- 
Ruadhán Gillecroisd
(Rohan Gilchrist)
07780 675 038



More information about the CentOS mailing list