[CentOS] Upgrading CentOS 5.3 to 5.4 errors

ken gebser at mousecar.com
Sun Oct 25 22:24:35 UTC 2009


On 10/24/2009 05:09 PM Rohan Gilchrist wrote:
> Hello,
> 
> I thought I'd wait a little while before upgrading to 5.4, but am 
> running into the following errors:
> 
> -> Finished Dependency Resolution
> lvm2-2.02.46-8.el5.i386 from base has depsolving problems
>   --> Missing Dependency: device-mapper >= 1.02.32-1 is needed by 
> package lvm2-2.02.46-8.el5.i386 (base)
> mkinitrd-5.1.19.6-54.i386 from base has depsolving problems
>   --> Missing Dependency: device-mapper-multipath >= 0.4.7-9 is needed 
> by package mkinitrd-5.1.19.6-54.i386 (base)
> lvm2-2.02.46-8.el5.i386 from base has depsolving problems
>   --> Missing Dependency: device-mapper-event is needed by package 
> lvm2-2.02.46-8.el5.i386 (base)
> Error: Missing Dependency: device-mapper-multipath >= 0.4.7-9 is needed 
> by package mkinitrd-5.1.19.6-54.i386 (base)
> Error: Missing Dependency: device-mapper-event is needed by package 
> lvm2-2.02.46-8.el5.i386 (base)
> Error: Missing Dependency: device-mapper >= 1.02.32-1 is needed by 
> package lvm2-2.02.46-8.el5.i386 (base)
> 
> It would appear that these packages do exist, although earlier versions:
> 
> # rpm -q device-mapper
> device-mapper-1.02.13-1.el5
> 
> Any thoughts would be appreaicated.
> 
> Regards,
> 
> Rohan.

I had some similar problems with my update, not with the same packages
as you, but with yum claiming that dependencies needed to be installed--
dependencies which *were* already installed.  All I did was a "yum
reinstall ..." on those dependencies and that fixed it.  In your case
"yum reinstall device-mapper" etc. might fix it.  Hope so.  Let us know.



More information about the CentOS mailing list