[CentOS] Upgrading Centos 5.3 -> 5.4

Rohan Gilchrist rohan at gilchrist.me
Mon Oct 26 20:49:28 UTC 2009


Still the same problems I'm afraid. I read the release notes and 
followed them to the letter.

I'm now seeing:

Finished Dependency Resolution
lvm2-2.02.46-8.el5.i386 from base has depsolving problems
 --> Missing Dependency: device-mapper >= 1.02.32-1 is needed by package 
lvm2-2.02.46-8.el5.i386 (base)
mkinitrd-5.1.19.6-54.i386 from base has depsolving problems
 --> Missing Dependency: device-mapper-multipath >= 0.4.7-9 is needed by 
package mkinitrd-5.1.19.6-54.i386 (base)
lvm2-2.02.46-8.el5.i386 from base has depsolving problems
 --> Missing Dependency: device-mapper-event is needed by package 
lvm2-2.02.46-8.el5.i386 (base)
Error: Missing Dependency: device-mapper-multipath >= 0.4.7-9 is needed 
by package mkinitrd-5.1.19.6-54.i386 (base)
Error: Missing Dependency: device-mapper-event is needed by package 
lvm2-2.02.46-8.el5.i386 (base)
Error: Missing Dependency: device-mapper >= 1.02.32-1 is needed by 
package lvm2-2.02.46-8.el5.i386 (base)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
                       package-cleanup --dupes
                       rpm -Va --nofiles --nodigest


I've installed package cleanup and tried the suggested combinations, 
except the --skip-broken option. Any thoughts are appreciated.

Rohan.



More information about the CentOS mailing list