[CentOS] yum Transaction Check Error: re: nvidia conflicts

Nicolas Thierry-Mieg Nicolas.Thierry-Mieg at imag.fr
Tue Feb 23 15:19:46 UTC 2010


Larry Vaden wrote:
> Googling this (specifically the nvidia-bug-report line below) doesn't
> find anything.
>
> This is a server (console is text only, no GUI), so we may not need
> x11 nor nvidia, I dunno for sure.
>
> Thanks in advance for your thoughts.
>
> kind regards/ldv
>
> Transaction Check Error:   file /usr/bin/nvidia-bug-report.sh from
> install of dkms-nvidia-x11-drv-185.18.14-1.nodist.rf conflicts with
> file from package nvidia-x11-drv-96xx-1.0.9631-1.nodist.rf

you forgot the command that leads to these errors, as well as the 
preceding output of that command, and maybe enabled repos etc...
but it seems you are trying to install conflicting packages, and yum is 
rightly refusing to do so.
nvidia-x11-drv-96xx is for older nvidia cards which are not supported by 
the newer drivers such as the 185.18.14.

A. you should find out whether your GPU needs version 96xx, or 173xx, or 
the latest driver. Then install only the rpms for that version.
B. you should use the elrepo versions rather than the rpmforge ones.
C. you should find out if you really need the nvidia proprietary driver 
on that server...


More information about the CentOS mailing list