[CentOS] good centos/rhel source for latest spamassassin?

Gary Greene ggreene at minervanetworks.com
Thu Feb 25 17:52:45 UTC 2010


On 2/25/10 5:31 AM, "Kai Schaetzl" <maillists at conactive.com> wrote:
> Eero Volotinen wrote on Thu, 25 Feb 2010 13:47:14 +0200:
> 
>> is there any nice way to install build requirements on buildserver?
> 
> Not sure what you mean by that, but all necessary Perl packages are
> available as rpm, for instance perl-Encode-Detect-1.01-1.el5.rf
> 
> What I usually do with SA is do a normal make and make test. That reveals
> any such dependencies and problems. If make test was successful I do the
> rpmbuild.
> 
> Kai

And if you _really_ need a particular module that is newer than rpmforge or
EPEL, there is always cpan2rpm. I don't recommend just letting it auto-build
the package. I tend to clear out the cruft from the spec file it generates
and then build that which creates a clean package.

-- 
Gary L. Greene, Jr.
IT Operations
Minerva Networks, Inc.
Cell:  (650) 704-6633
Phone: (408) 240-1239



More information about the CentOS mailing list