[CentOS] Sendmail error: auxpropfunc error invalid parameter supplied

Jussi Hirvi listmember at greenspot.fi
Mon Jan 4 14:22:36 UTC 2010


On 4.1.2010 11:42, Eero Volotinen wrote:
> Quoting Jussi Hirvi <listmember at greenspot.fi>:
> 
>> I just noticed this error in my messages log after restarting sendmail.
>>
>> The only change I have made is
>> 1) manual fix in /usr/share/spamassassin/72_active.conf
>> 2) sa-update (several times)
>>
>> Now the mail is not running ok, my mail queue keeps growing.
>>
>> Regards,
>> Jussi Hirvi
>>
>> _______________________________________________
>> CentOS mailing list
>> CentOS at centos.org
>> http://lists.centos.org/mailman/listinfo/centos
>>
> 
> sounds like this:
> https://bugzilla.redhat.com/show_bug.cgi?id=167300
> 
> -- 
> Eero

That was it! I applied the "workaround" described on that page, and now
there are no error messages in the messages log anymore.

And btw, this was *not* what blocked my emails.
The email block was caused by amavisd error,
which was caused by missing File::Temp perl package,
which was caused by a recent perl update (yum update).

Solution: I installed File::Temp from MCSPAN.

Both problems ("auxpropfunc"... and File::Temp) surfaced only now that I
finally restarted sendmail.

Regards,
Jussi

-- 
Jussi Hirvi * Green Spot
Topeliuksenkatu 15 C * 00250 Helsinki * Finland
Tel. +358 9 493 981 * Mobile +358 40 771 2098 (only sms)
jussi.hirvi at greenspot.fi * http://www.greenspot.fi


More information about the CentOS mailing list