[CentOS] Can't Compile Driver due to Missing version.h

Mufit Eribol hme at onart.com.tr
Fri Jan 8 12:24:51 UTC 2010


Dear All,

I use a raid card on my Centos 5.4 server. Whenever I updated the 
kernel, I used to compile drivers of the card for the new kernel. I have 
done this many times in the past without any problem.

But this time after installing the new kernel files given below, I can 
not compile the new driver anymore.

kernel-headers-2.6.18-164.9.1.el5
kernel-PAE-devel-2.6.18-164.9.1.el5
kernel-PAE-2.6.18-164.9.1.el5

The make command can not find /include/linux/version.h file with the 
following error. But the file is already there.

make KERNELDIR= /lib/modules/2.6.18-164.9.1.el5PAE/build
grep: /include/linux/version.h: No such file or directory
expr: syntax error
../../../inc/linux/Makefile.def:85: *** Only kernel 2.4/2.6 is supported 
but you use 2..  Stop.

[root at server linux]#locate include\/linux\/version.h command gives the 
following result.

/usr/include/linux/version.h
/usr/src/kernels/2.6.18-128.1.1.el5-PAE-i686/include/linux/version.h
/usr/src/kernels/2.6.18-164.9.1.el5-PAE-i686/include/linux/version.h
/usr/src/kernels/2.6.18-92.1.18.el5-PAE-i686/include/linux/version.h

I would appreciate any help.

Thank you.
Mufit Eribol



More information about the CentOS mailing list