[CentOS] ADSL ppp0, persist

JohnS jses27 at gmail.com
Sun Jan 10 16:49:29 UTC 2010


On Sun, 2010-01-10 at 16:54 +0100, David Hláčik wrote:
> Hello guys,
> 
> I have two ISP's connected to my router. One via eth2, second one via
> ADSL modem, with ppoe doing on my Centos 5 .
> 
> The problem I have is, that when ADSL fails , interface ppp0 is
> removed. This also removes my static routes configured for this
> interface. I do not want that, as I have load balancing configured and
> default route is removed when ppp0 interface disapears.
> 
> This is my ifcfg-ppp0 config :
> 
> USERCTL=yes
> BOOTPROTO=dialup
> NAME=DSLppp0
> DEVICE=ppp0
> TYPE=xDSL
> ONBOOT=yes
> PIDFILE=/var/run/pppoe-adsl.pid
> FIREWALL=NONE
> PING=.
> PPPOE_TIMEOUT=80
> LCP_FAILURE=3
> LCP_INTERVAL=20
> CLAMPMSS=1412
> CONNECT_POLL=6
> CONNECT_TIMEOUT=60
> DEFROUTE=no
> SYNCHRONOUS=no
> ETH=eth0
> PROVIDER=DSLppp0
> USER=O2
> PEERDNS=no
> DEMAND=no
> PERSIST=yes
> 
> As you can see, I have PERSIST=yes , which according to documentation
> should keep ppp0 interface ON. Well it does but only for a couple of
> seconds. I suspect this to be other parameters problem
> (CONNECT_TIMEOUT or PPPOE_TIMEOUT).
> 
> Can you please help me with this?
> 
> Thank you in advance!
> 
> David
---
Maybe not really that since you have it set to "yes".
Check /var/log/messages for Authentication Problems, like CHAP, MSCHAP
or Tokin ID Session.  I would really get a router to do the balancing
not the OS it self.

John



More information about the CentOS mailing list