[CentOS] Just installed DomU won't boot

Lucian @ lastdot.org lucian at lastdot.org
Fri Jan 22 18:09:00 UTC 2010


On Fri, Jan 22, 2010 at 5:50 PM, Sergio Belkin <sebelk at gmail.com> wrote:
> Hi, I am using Centos 5.4 x86_64 with kernel 2.6.18-164.11.1.el5xen.
> I've installed a Centos 5.4 (64 bit too) DomU (paravirtualized),
> process was apparently with no problems, but DomU refuses to start,
> this the error:
>
> Traceback (most recent call last):
>  File "/usr/share/virt-manager/virtManager/engine.py", line 498, in run_domain
>    vm.startup()
>  File "/usr/share/virt-manager/virtManager/domain.py", line 573, in startup
>    self.vm.create()
>  File "/usr/lib64/python2.4/site-packages/libvirt.py", line 287, in create
>    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
> libvirtError: La operación POST falló: xend_post: error del demonio de
> xen: (xend.err "Error creating domain: Boot loader didn't return any
> data!")
>
> End of Error Message.
>
> Config file is as follows:
>
> name = "fido"
> uuid = "af13748d-6084-2357-73b7-0c7ff9ed9553"
> maxmem = 1500
> memory = 1500
> vcpus = 16
> bootloader = "/usr/bin/pygrub"
> on_poweroff = "destroy"
> on_reboot = "restart"
> on_crash = "restart"
> vfb = [ "type=vnc,vncunused=1,keymap=es" ]
> disk = [ "phy:/dev/VolGroup00/LogVol02,xvda,w" ]
> vif = [ "mac=00:16:36:19:a7:66,bridge=xenbr0,script=vif-bridge" ]
>
>
> Please could you tell me what'w wrong with it?
>
> Thanks in advance!!
>
>
> --
> --
> Open Kairos http://www.sergiobelkin.com
> Watch More TV http://sebelk.blogspot.com
> Sergio Belkin -
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos
>

What happens if you run:

pygrub /dev/VolGroup00/LogVol02

I suspect you don't have the required stuff (kernel, initrd and
menu.lst/grub.conf) in your domU's /boot dir.


More information about the CentOS mailing list