[CentOS] wifi doesnt work on centos 5.4

Arvind P R iinfi1 at gmail.com
Sat Jan 23 11:00:06 UTC 2010


hi there
thanks for that reply
i didnt know NetworkManager existed as a different service in centos!! all
this while i used the network service to start n stop the network services!!
i thought network and NetworkManager are one n the same.

thanks for the insight. i m writing this mail while connected to my wireless
router thru the wifi :)

thanks a lot
Arvind


On Sat, Jan 23, 2010 at 1:23 PM, Agile Aspect <agile.aspect at gmail.com>wrote:

> On Fri, Jan 22, 2010 at 11:20 PM, Arvind P R <iinfi1 at gmail.com> wrote:
> > hi all,
> > this is my first hit on the mailing list. hope i m posting in the right
> > place.
> > well, i have a dell vostro 1510 laptop with broadcom wifi adapter. n it
> > doesnt work! :(
> > i installed the wifi drivers with ndiswrapper.
> >
> > iwconfig shows the following.
> >
> > [root at laptop ~]# iwconfig
> > lo        no wireless extensions.
> >
> > eth0      no wireless extensions.
> >
> > sit0      no wireless extensions.
> >
> > wlan0     IEEE 802.11g  ESSID:off/any  Nickname:"laptop"
> >           Mode:Managed  Frequency:2.417 GHz  Access Point: Not-Associated
> >           Bit Rate=54 Mb/s   Tx-Power:32 dBm
> >           RTS thr=2347 B   Fragment thr=2346 B
> >           Encryption key:off
> >           Power Management:off
> >           Link Quality:0  Signal level:0  Noise level:0
> >           Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
> >           Tx excessive retries:0  Invalid misc:0   Missed beacon:0
> >
> > strangely i cannot find the wlan0 config file in the
> > /etc/sysconfig/network-scripts/!!
> >
> > [root at laptop ~]# iwlist wlan0 scanning
> >
> > wlan0     Scan completed :
> >           Cell 01 - Address: 00:xx:xx:91:xx:xx
> >                     ESSID:"thephenomenon"
> >                     Protocol:IEEE 802.11g
> >                     Mode:Managed
> >                     Frequency:2.412 GHz (Channel 1)
> >                     Quality:78/100  Signal level:-46 dBm  Noise level:-96
> > dBm
> >                     Encryption key:on
> >                     Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
> >                               18 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 12 Mb/s
> >                               24 Mb/s; 48 Mb/s
> >                     Extra:bcn_int=100
> >                     Extra:atim=0
> >                     IE: WPA Version 1
> >                         Group Cipher : TKIP
> >                         Pairwise Ciphers (2) : TKIP CCMP
> >                         Authentication Suites (1) : PSK
> >                     IE: IEEE 802.11i/WPA2 Version 1
> >                         Group Cipher : TKIP
> >                         Pairwise Ciphers (2) : TKIP CCMP
> >                         Authentication Suites (1) : PSK
> >
> > i generated a wpa_passphrase and wpa_supplicant.conf is as follows
> >
> > [root at laptop ~]# cat /etc/wpa_supplicant/wpa_supplicant.conf
> > ctrl_interface=/var/run/wpa_supplicant
> > ctrl_interface_group=wheel
> >
> > network={
> >         ssid="thephenomenon"
> >         key_mgmt=WPA-PSK
> >
> psk=88a745bb68f4ff4fae41xxxxxxxxxxxxx5b1a66341ced3cxxxxxx2167b218d8c
> > }
> >
> > now when i do a
> > [root at laptop ~]# wpa_supplicant -Dwext -iwlan0
> -c/etc/wpa_supplicant.conf
> > Failed to read or parse configuration '/etc/wpa_supplicant.conf'.
> > [root at laptop ~]#
> >
> > i get the above error. i have a WPA encryption in my router.
> >
> > infact earlier i used to get a connected status when i tried to connect
> it
> > with wpa_gui once. but later i think i have screwed the config a bit
> >
> > sorry for the long post... can someone plz guide me from here?
> >
> > _______________________________________________
> > CentOS mailing list
> > CentOS at centos.org
> > http://lists.centos.org/mailman/listinfo/centos
> >
> >
>
> Try
>
>   yum install wpa_supplicant
>   yum install NetworkManager\*
>   service NetworkManager start
>
> --
>      Enjoy global warming while it lasts.
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.centos.org/pipermail/centos/attachments/20100123/21394560/attachment.html 


More information about the CentOS mailing list