[CentOS] streamripper & CentOS?

Michael A. Peters mpeters at mac.com
Mon Jan 25 00:01:16 UTC 2010


Nicolas Thierry-Mieg wrote:
> Brian wrote:
>> checking for GLIB - version>= 2.16.0... no
>> *** Could not run GLIB test program, checking why...
>> *** The test program failed to compile or link. See the file
>> config.log for the
>> *** exact error that occured. This usually means GLIB is incorrectly
>> installed.
>> configure: error: Glib 2.16 or greater required
> 
> that's glib not glibc.
> Current version in C5 is
> $ rpm -q glib2
> glib2-2.12.3-4.el5_3.1
> 
> your program needs a newer glib than that provided in C5.
> I don't know how this could be solved, but probably not easily.

glib is set up so that you can install parallel versions.

Get the src.rpm from a newer distro, change the name to
compat-glib2 and tweak the spec file to build with the changed name and add

Provides: glib2 = %{version}

(and for devel - Provides glib2-devel = %{version}

Build it and it should install parallel to the stock glib2.

Of course, you may need to do the same thing with some dependencies just 
to get the compat-glib2 to build.

I might have a spec file for updated glib2 sitting around somewhere, but 
I stopped using CentOS for desktop so if that is one of the libs I had 
updated for myself, it may be older than 2.16 (I seem to remember doing 
it for 2.14) but I'll see if I have it. It may have been archived to one 
of my DVD's if I do, and I never built an index of what was on them. But 
I'll see if I can find it.


More information about the CentOS mailing list