[CentOS] Yum update failure (was a digest reference)

Eero Volotinen eero.volotinen at iki.fi
Mon Jan 25 21:32:58 UTC 2010


2010/1/25 Tobias Weisserth <tobias.weisserth at gmail.com>:
> Thanks for the hint, but still no luck:
> [root at hostname ~]# yum clean all
> Loaded plugins: fastestmirror, priorities
> Cleaning up Everything
> Cleaning up list of fastest mirrors
> [root at hostname ~]# yum update
> Loaded plugins: fastestmirror, priorities
> Determining fastest mirrors
>  * addons: mirror.netcologne.de
>  * atomic: www4.atomicorp.com
>  * base: mirror.netcologne.de
>  * centosplus: mirror.netcologne.de
>  * extras: mirror.netcologne.de
>  * rpmforge: ftp-stud.fht-esslingen.de
>  * updates: mirror.netcologne.de
> addons
>
>    |  951 B     00:00
> addons/primary
>
>    |  201 B     00:00
> atomic
>
>    | 1.9 kB     00:00
> atomic/primary_db
>
>     | 304 kB     00:00
> base
>
>    | 2.1 kB     00:00
> base/primary_db
>
>     | 1.6 MB     00:00
> centosplus
>
>    |  951 B     00:00
> centosplus/primary
>
>    | 157 kB     00:00
> centosplus
>
>                   183/183
> extras
>
>    | 1.1 kB     00:00
> extras/primary
>
>    | 107 kB     00:00
> extras
>
>                   325/325
> rpmforge
>
>    | 1.1 kB     00:00
> rpmforge/primary
>
>    | 3.6 MB     00:00
> rpmforge
>
>               10064/10064
> updates
>
>     | 1.9 kB     00:00
> updates/primary_db
>
>    | 459 kB     00:00
> utterramblings
>
>    |  951 B     00:00
> utterramblings/primary
>
>    |  23 kB     00:00
> utterramblings
>
>                     69/69
> Excluding Packages from CentOS-5 - Base
> Finished
> Excluding Packages from CentOS-5 - Plus
> Finished
> Reducing CentOS-5 - Plus to included packages only
> Finished
> Excluding Packages from CentOS-5 - Updates
> Finished
> 556 packages excluded due to repository priority protections
> Setting up Update Process
> Resolving Dependencies
> --> Running transaction check
> ---> Package util-linux.i386 0:2.13-0.52.el5_4.1 set to be updated
> --> Processing Dependency: libc.so.6(GLIBC_2.4) for package: util-linux
> --> Processing Dependency: libc.so.6(GLIBC_2.0) for package: util-linux
> --> Processing Dependency: rtld(GNU_HASH) for package: util-linux
> --> Processing Dependency: libutil.so.1(GLIBC_2.0) for package: util-linux
> --> Processing Dependency: libc.so.6(GLIBC_2.2) for package: util-linux
> --> Processing Dependency: libc.so.6 for package: util-linux
> --> Processing Dependency: libc.so.6(GLIBC_2.3) for package: util-linux
> --> Processing Dependency: libcrypt.so.1 for package: util-linux
> --> Processing Dependency: libc.so.6(GLIBC_2.3.4) for package: util-linux
> --> Processing Dependency: libc.so.6(GLIBC_2.1) for package: util-linux
> --> Processing Dependency: libutil.so.1 for package: util-linux
> --> Running transaction check
> ---> Package glibc.i686 0:2.5-42.el5_4.3 set to be updated
> --> Processing Dependency: glibc-common = 2.5-42.el5_4.3 for package: glibc
> --> Running transaction check
> ---> Package glibc-common.i386 0:2.5-42.el5_4.3 set to be updated
> --> Finished Dependency Resolution
> Dependencies Resolved
> ===================================================================================================================================================================================
>  Package                                      Arch
>       Version                                           Repository
>                     Size
> ===================================================================================================================================================================================
> Updating:
>  util-linux                                   i386
>       2.13-0.52.el5_4.1                                 updates
>                     1.8 M
> Installing for dependencies:
>  glibc                                        i686
>       2.5-42.el5_4.3                                    updates
>                     5.2 M
>  glibc-common                                 i386
>       2.5-42.el5_4.3                                    updates
>                      16 M
> Transaction Summary
> ===================================================================================================================================================================================
> Install      2 Package(s)
> Update       1 Package(s)
> Remove       0 Package(s)
> Total download size: 24 M
> Is this ok [y/N]: y
> Downloading Packages:
> (1/3): util-linux-2.13-0.52.el5_4.1.i386.rpm
>
>    | 1.8 MB     00:00
> (2/3): glibc-2.5-42.el5_4.3.i686.rpm
>
>    | 5.2 MB     00:00
> (3/3): glibc-common-2.5-42.el5_4.3.i386.rpm
>
>     |  16 MB     00:02
> -----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
> Total
>                                                                        8.2
> MB/s |  24 MB     00:02
> Running rpm_check_debug
> Running Transaction Test
> Finished Transaction Test
> Transaction Test Succeeded
> Running Transaction
>   Installing     : glibc-common
>
>                        1/4
> Error unpacking rpm package glibc-common-2.5-42.el5_4.3.i386
> error: unpacking of archive failed on file /usr/share/i18n: cpio: mkdir
>   Installing     : glibc
>
>                       2/4
> Error unpacking rpm package glibc-2.5-42.el5_4.3.i686
> warning: /etc/localtime created as /etc/localtime.rpmnew
> error: unpacking of archive failed on file /lib/i686: cpio: mkdir
>   Updating       : util-linux
>
>                        3/4
> Error unpacking rpm package util-linux-2.13-0.52.el5_4.1.i386
> error: unpacking of archive failed on file
> /usr/share/locale/id/LC_MESSAGES/util-linux.mo;4b5e0c03: cpio: mkdir
> Failed:
>   glibc.i686 0:2.5-42.el5_4.3                           glibc-common.i386
> 0:2.5-42.el5_4.3                           util-linux.i386
> 0:2.13-0.52.el5_4.1
> Complete!
> I am at a loss here. What's wrong?
> Thanks for any help,
> Tobias

Is disk and hardware working ok?

--
Eero


More information about the CentOS mailing list