[CentOS] yum update error

Majian jiannma at gmail.com
Sat Jan 30 12:32:06 UTC 2010


Hi ,all :

Today I run the "yum update" command on my laptop, which is CentOS 5.4 i386.
Then the screen displays the following message :

root at kuku ~ > yum update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * addons: mirror.centos.net.cn
 * base: mirror.centos.net.cn
 * epel: mirrors.sohu.com
 * extras: mirror.centos.net.cn
 * rpmforge: ftp-stud.fht-esslingen.de
 * rpmfusion-free-updates: mirrors.cat.pdx.edu
 * rpmfusion-free-updates-testing: mirrors.cat.pdx.edu
 * rpmfusion-nonfree-updates: mirrors.cat.pdx.edu
 * rpmfusion-nonfree-updates-testing: mirrors.cat.pdx.edu
 * update: mirrors.163.com
Setting up Update Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: liblua-5.1.so for package: mysql-proxy
---> Package lua.i386 0:5.1.4-1.el5.rf set to be updated
---> Package lua-devel.i386 0:5.1.4-1.el5.rf set to be updated
--> Finished Dependency Resolution
mysql-proxy-0.5.1-1.el5.i386 from installed has depsolving problems
  --> Missing Dependency: liblua-5.1.so is needed by package
mysql-proxy-0.5.1-1.el5.i386 (installed)
Error: Missing Dependency: liblua-5.1.so is needed by package
mysql-proxy-0.5.1-1.el5.i386 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest


Then I run "yum update --skip-broken", but after I run that command ,
the screen displays these:

root at kuku ~ > yum update --skip-broken
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * addons: mirrors.163.com
 * base: mirrors.163.com
 * epel: mirrors.sohu.com
 * extras: mirrors.163.com
 * rpmforge: ftp-stud.fht-esslingen.de
 * rpmfusion-free-updates: mirrors.cat.pdx.edu
 * rpmfusion-free-updates-testing: mirrors.cat.pdx.edu
 * rpmfusion-nonfree-updates: mirrors.cat.pdx.edu
 * rpmfusion-nonfree-updates-testing: mirrors.cat.pdx.edu
 * update: mirrors.163.com
Setting up Update Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: liblua-5.1.so for package: mysql-proxy
---> Package lua.i386 0:5.1.4-1.el5.rf set to be updated
---> Package lua-devel.i386 0:5.1.4-1.el5.rf set to be updated
--> Finished Dependency Resolution
mysql-proxy-0.5.1-1.el5.i386 from installed has depsolving problems
  --> Missing Dependency: liblua-5.1.so is needed by package
mysql-proxy-0.5.1-1.el5.i386 (installed)
--> Running transaction check
---> Package lua.i386 0:5.1.4-1.el5.rf set to be updated
--> Processing Dependency: lua = 5.1.4-1.el5.rf for package: lua-devel
--> Finished Dependency Resolution
lua-devel-5.1.4-1.el5.rf.i386 from rpmforge has depsolving problems
  --> Missing Dependency: lua = 5.1.4-1.el5.rf is needed by package
lua-devel-5.1.4-1.el5.rf.i386 (rpmforge)

Packages skipped because of dependency problems:
    lua-5.1.4-1.el5.rf.i386 from rpmforge
    lua-devel-5.1.4-1.el5.rf.i386 from rpmforge

Could someone give me some advices?

Thanks in advance ~
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.centos.org/pipermail/centos/attachments/20100130/5ef41e31/attachment.html 


More information about the CentOS mailing list