[CentOS] strange network problem

Michael Schumacher michael.schumacher at pamas.de
Thu Mar 4 11:00:42 UTC 2010


Hi,
I am trying to fix a problem I have for about a week now.
The environment is:
--several independent servers with Centos5.4 on the latest patchlevel
(example will be server2) All of them are working properly.
--a machine with Xen installed to host some virtual machines
(xenserver1)
--domu servers on xenserver1 (crmserver1, winserver1)

The whole network is connected with a Lancom router to a DSL line.

Some days ago I noticed that server2 was updated properly, but
xenserver1, crmserver1 and winserver were not updating the OS
properly. They seemed to be cut off the internet. I can ping from all
to all servers internally, I can ssh from all to  all servers
internally and I can browse the Internet from server2 successfully
(using IP-numbers and hostnames), but xenserver1 and its domu clients
could not connect to the internet. I checked the firewalls on
xenserver, and crmserver1. They seemed to be OK and stopping them with
"etc/init.d/iptables stop" didn't solve the problem.

I can resolve hostnames:

>[root at xenserver1 ~]# nslookup www.centos.org
>Server:         192.168.1.1
>Address:        192.168.1.1#53
>
>Non-authoritative answer:
>Name:   www.centos.org
>Address: 72.232.194.162

but I cannot browse neither to "elinks http://www.centos.org" nor to
72.232.194.162, however, I can ping www.centos.org successfully.


the network routes seem to be OK :

>[root at xenserver1 ~]# route
>Kernel IP routing table
>Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
>10.1.1.0        *               255.255.255.0   U     0      0        0 eth1
>192.168.122.0   *               255.255.255.0   U     0      0        0 virbr0
>169.254.0.0     *               255.255.0.0     U     0      0        0 eth0
>192.168.0.0     *               255.255.0.0     U     0      0        0 eth0
>default         LANCOM_1751_1.p 0.0.0.0         UG    0      0        0 eth0

(eth1 is a drbd interface)

> [root at crmserver1 ~]# route
> Kernel IP routing table
> Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
> 169.254.0.0     *               255.255.0.0     U     0      0        0 eth0
> 192.168.0.0     *               255.255.0.0     U     0      0        0 eth0
> default         LANCOM_1751_1.p 0.0.0.0         UG    0      0        0 eth0



Has anybody any clue where to look?

 
best regards
---
Michael Schumacher
PAMAS Partikelmess- und Analysesysteme GmbH
Dieselstr.10, D-71277 Rutesheim
Tel +49-7152-99630
Fax +49-7152-996333
Geschäftsführer: Gerhard Schreck
Handelsregister B Stuttgart HRB 252024



More information about the CentOS mailing list