[CentOS] [Possibly OT] rpm conflicts has me confused

Bob Beers bob.beers at gmail.com
Thu Mar 4 19:50:28 UTC 2010


Hi list,

I can install the default  ppp-2.4.4-2, but when I try to
 install an rpm I built from Sangoma's ppp-2.4.4.5 (using
 checkinstall-1.6.1) I get this error:

# rpm -ivh ppp.2.4.4.5-1.eai.i386.rpm

error: Failed dependencies:
     ppp < 2.4.3-3 conflicts with kernel-2.6.18-162.2.1.el5.i686

Isn't 2.4.4.5 > 2.4.3-3 ???


trying this:

yum localinstall ppp.2.4.4.5-1.eai.i386.rpm --nogpgcheck

gives some advice:

 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                                    package-cleanup --dupes
                                    rpm -Va --nofiles --nodigest

and I tried each of those, but no joy.

Is this an rpm bug, a checkinstall bug, or PEBKAC
(problem exists between keyboard and chair)?

thanks,
-Bob Beers


More information about the CentOS mailing list