[CentOS] Dependency problems with Yum update

Todd Cary todd at aristesoftware.com
Thu Mar 11 05:10:26 UTC 2010


Craig -

I ran 966 and 967 below.  Then

   968  wget http://rubyforge.org/frs/download.php/57643/rubygems-1.3.4.tgz
   969  tar xvzf rubygems
   970  find / -name rubygems*
   971  tar xvzf /root/rubygems-1.3.4.tgz
   972  ruby rubygems-1.3.4/setup.rb
   973  gem install rails

Next I used gem to install sqlite3 on the suggestion that I needed to 
have the gem version only to find out that I needed sqlite3-ruby, so I 
uninstalled sqlite3 and tried to install via gem sqlite3-ruby, but it 
cannot be installed without ruby 1.8.6.

Todd

On 3/10/2010 7:19 PM, Craig White wrote:
> On Wed, 2010-03-10 at 17:21 -0800, Todd Cary wrote:
>    
>> Augusto -
>>
>> What is the syntax for that?  This is what I initially ran:
>>
>>    966  gvim /etc/yum.repos.d/CentOS-Testing.repo
>>    967  yum --enablerepo=testing install ruby ruby-devel ruby-rdoc
>>
>>      
> ----
> ignore that - you don't need to run createrepo
>
> what did you change when you edited CentOS-Testing.repo ?
>
> btw... I tend to install more ruby bits (example from EL5)
> ruby-ri-1.8.5-5.el5_3.7
> ruby-rdoc-1.8.5-5.el5_3.7
> ruby-devel-1.8.5-5.el5_3.7
> ruby-libs-1.8.5-5.el5_3.7
> ruby-mode-1.8.5-5.el5_3.7
> ruby-1.8.5-5.el5_3.7
> ruby-irb-1.8.5-5.el5_3.7
>
> but I suspect that ruby-libs is automatically pulled in with your above
> yum command.
>
> Craig
>
>
>    

-- 
Ariste Software
Petaluma, CA 94952

http://www.toddcary.com/aristephotography/



More information about the CentOS mailing list