[CentOS] drbd-kmdl packages question

Akemi Yagi amyagi at gmail.com
Thu Mar 11 17:35:06 UTC 2010


On Thu, Mar 11, 2010 at 9:30 AM, Akemi Yagi <amyagi at gmail.com> wrote:
> On Thu, Mar 11, 2010 at 9:19 AM, Nicholas L. Soms <nsoms at linux-ink.ru> wrote:
>> Dear collegues!
>>
>> I've got one question about drbd-kmdl packages.
>> As I can see at
>> $ rpm -qp --qf "%{DESCRIPTION}" kmod-drbd-8.0.16-5.el5_3.i686.rpm
>> This package provides the drbd kernel modules built for the Linux
>> kernel 2.6.18-128.4.1.el5 for the i686 family of processors.
>>
>> So, the question is - kmod-drbd is for kernel 128.4.1 (or build for this
>> kernel version), but current kernel is 164.11.1. Does that means that
>> kmod-drbd should be rebuild for each kernel or it works vell without
>> rebuild?
>
> No, it is a kernel version independent, kABI-tracking kernel module.
> So, it should survive each kernel update. No need for rebuilding.  (It
> is different from drbd-kmdl)

Oh, and yes, that description should be changed to reflect the fact. :-D

Ralph? Are you the dev in charge of the maintenance?

Akemi


More information about the CentOS mailing list