[CentOS] Dependency problems with Yum update

Todd Cary todd at aristesoftware.com
Thu Mar 11 18:46:54 UTC 2010


On 3/11/2010 9:25 AM, Akemi Yagi wrote:
> On Thu, Mar 11, 2010 at 9:04 AM, Todd Cary<todd at aristesoftware.com>  wrote:
>
>    
>> I am obviously missing something since a cat of the repo file shows it
>> disabled and I still get the same errors.
>>
>> [testing]
>> name=CentOS-$releasever - Testing
>> arch=$basearch&repo=testing
>> baseurl=http://dev.centos.org/centos/$releasever/testing/$basearch/
>> gpgcheck=1
>> enable=0
>> gpgkey=http://dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing
>>      
> The "authentic" testing repo file for CentOS-4 has these lines:
>
> [c4-testing]
> name=CentOS-4 Testing
> baseurl=http://dev.centos.org/centos/$releasever/testing/$basearch/
> enabled=0
> gpgcheck=1
> gpgkey=http://dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing
>
> Yours is apparently different (even the repo name).  Where did you get it from?
>
> Akemi
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos
>
>
>    
I needed a current version of Ruby and Rails and was advised to do the 
following:

   966  gvim /etc/yum.repos.d/CentOS-Testing.repo
   967  yum --enablerepo=testing install ruby ruby-devel ruby-rdoc
   968  wget http://rubyforge.org/frs/download.php/57643/rubygems-1.3.4.tgz
   969  tar xvzf rubygems
   970  find / -name rubygems*
   971  tar xvzf /root/rubygems-1.3.4.tgz
   972  ruby rubygems-1.3.4/setup.rb
   973  gem install rails

Todd

-- 
Ariste Software
Petaluma, CA 94952

http://www.toddcary.com/aristephotography/



More information about the CentOS mailing list