[CentOS] Upgrading Python with Yum

Akemi Yagi amyagi at gmail.com
Mon Mar 22 15:08:43 UTC 2010


On Mon, Mar 22, 2010 at 6:51 AM, Susan Day <suzieprogrammer at gmail.com> wrote:
> Hi;
> I have an old version of Python (2.4.3) and I'm trying to upgrade (to 2.6);
> however, when I try
> yum upgrade python
> it tells me that it's already got the latest and greatest...presumably of
> 2.4.3. I've tried
> yum list python
> and it only gives me the 2.4.3. Are there no others? Do I have to build from
> a tarball? I'm surprised I don't find a version of Python 3 either. In what
> folder are the rpms kept?

You might want to read this FAQ:

"Where can I get the latest version of XyZ.rpm for CentOS? I cannot
find it anywhere."
( http://wiki.centos.org/FAQ/General#head-472ce8446ebcfc82ca1800f775ba0e629ac835c7
)

Cheers,
Akemi


More information about the CentOS mailing list