[CentOS] Ruby-1.9.1+ rpm for CentOS-5

Karanbir Singh mail-lists at karan.org
Tue Mar 23 13:38:37 UTC 2010


On 03/22/2010 06:11 PM, James B. Byrne wrote:
> Does anyone have the url of a repository that provides Ruby-1.9.1+
> for CentOS-5 and which they consider a trustworthy and reliable
> source?
>
> I really do not what to have to build this software if I can avoid it.

1.9.1 isnt easy to shoehorn into parallen in the existing 1.8.5 space, 
specially if you want to use apps that run on either ( eg. puppet isnt 
1.9.x friendly; and there are plenty others as well ).

I've gone down the route of building a ruby-ee and ruby-191 into /opt 
name space and using that ( and have the developers rvm their local 
instances, whatever OS they are on ).

My ruby-191 packaging includes a fair bit of local site only info ( eg. 
I upgrade gem to 1.3.6 with an update_system during buildtime ). If 
there is any interest in these rpms, I dont mind putting in a bit of 
time and cleaning it out.

Having said all this - Jeroen is very close to getting a good package 
set together ( look at: http://www.kanarip.com/custom/el5-ruby/ )

- KB


More information about the CentOS mailing list