[CentOS] bogus error message from yum update for gmime and gmime-sharp

ken gebser at mousecar.com
Mon Mar 29 13:21:14 UTC 2010


When I do "yum update gmime gmime-sharp" I get:

...
  --> Missing Dependency: gmime = 2.2.10-5.el5.centos is needed by
package gmime-sharp-2.2.10-5.el5.centos.i386 (installed)
Error: Missing Dependency: gmime = 2.2.10-5.el5.centos is needed by
package gmime-sharp-2.2.10-5.el5.centos.i386 (installed)
...

But both of these are already installed:

# rpm -q gmime gmime-sharp
gmime-2.2.10-5.el5.centos
gmime-sharp-2.2.10-5.el5.centos

So:

# package-cleanup --problems
Setting up yum
Reading local RPM database
Processing all local requires
No problems found

Running the above "yum update ..." again yields the same bogus error
messages.  I've had problems with these two packages before.  Why can't
yum understand rpm for them?


Thanks for the wisdom.


-- 
Find research and analysis on US healthcare, health insurance,
and health policy at: <http://healthpolicydaily.blogspot.com/>


More information about the CentOS mailing list