[CentOS] openldap fails to authenticate

Tim Dunphy bluethundr at gmail.com
Tue Nov 2 16:28:43 EDT 2010


I am attempting to setup an LDAP server under CentOS 5.4.


However I  am unable to search my ldap directory even tho I am
supplying the proper credentials for the Manager account:


[root at ldap openldap]# ldapsearch -x -h ldap -D
'cn=Manager,dc=example,dc=net' -W -b 'dc=example,dc=net'
Enter LDAP Password:
ldap_bind: Invalid credentials (49)

Anonymous searches do work however:

ldapsearch -x -h ldap -b "dc=example,dc=net" -s sub "objectclass=*"

[root at ldap openldap]# ldapsearch -x -h ldap -b "dc=example,dc=net" -s
sub "objectclass=*"
# extended LDIF
#
# LDAPv3
# base <dc=example,dc=net> with scope subtree
# filter: objectclass=*
# requesting: ALL
#

# search result
search: 2
result: 32 No such object


I am currently attempting to use the actual word 'secret' to
authenticate the Manager account:

database        bdb
suffix          "dc=example,dc=net"
rootdn          "cn=Manager,dc=example,dc=net"
# Cleartext passwords, especially for the rootdn, should
# be avoided.  See slappasswd(8) and slapd.conf(5) for details.
# Use of strong authentication encouraged.
 rootpw                secret
# rootpw                 {CRYPT}secret


And I am getting error 49's in my openldap logs with loglevel set to 296

/var/log/openldap.log

Nov  2 15:45:58 ldap slapd[3522]: slapd starting
Nov  2 15:46:14 ldap slapd[3522]: conn=0 fd=11 ACCEPT from
IP=127.0.0.1:44552 (IP=0.0.0.0:389)
Nov  2 15:46:14 ldap slapd[3522]: conn=0 op=0 BIND
dn="cn=Manager,dc=example,dc=net" method=128
Nov  2 15:46:14 ldap slapd[3522]: conn=0 op=0 RESULT tag=97 err=49 text=
Nov  2 15:46:14 ldap slapd[3522]: conn=0 fd=11 closed (connection lost)


this is how I have configured my ldap.conf

BASE    dc=example,dc=net
HOST    localhost
URI     ldap://ldap.example.net

and for some reason slapd is listening on port 3774 even tho I haven't
told it to:

[root at ldap network-scripts]# netstat -tulnp | grep 389
tcp        0      0 0.0.0.0:389                 0.0.0.0:*
     LISTEN      3774/slapd
[root at ldap network-scripts]# netstat -tulnp | grep slapd
tcp        0      0 0.0.0.0:389                 0.0.0.0:*
     LISTEN      3774/slapd

I haven't specified port 3774 _anywhere_ in my ldap config:


[root at ldap network-scripts]# grep 3774 /etc/ldap


thanks in advance for your help







-- 
Here's my RSA Public key:
gpg --keyserver pgp.mit.edu --recv-keys 5A4873A9

Share and enjoy!!


More information about the CentOS mailing list