[CentOS] Nagios installation problem

Ben McGinnes ben at adversary.org
Fri Nov 5 14:21:50 EDT 2010


Hello,
	Has anyone managed a successful installation of Nagios using
the RPMForge packages on CentOS 5.5?

It looks like it should have worked, I followed the guides for Fedora
and CentOS here (with appropriate path adjustments):

http://nagios.sourceforge.net/docs/3_0/quickstart-fedora.html
http://wiki.centos.org/HowTos/Nagios

The SELinux policies look fine (I tend to ignore instructions to
permanently disable SELinux, if I'm not using SELinux then there's no
reason not to return to Slackware):

# semodule -l | grep nagios
nagios	1.1.0
#

The nagios.cfg check gave the all clear:

Reading configuration data...
   Read main config file okay...
Processing object config file '/etc/nagios/objects/commands.cfg'...
Processing object config file '/etc/nagios/objects/contacts.cfg'...
Processing object config file '/etc/nagios/objects/timeperiods.cfg'...
Processing object config file '/etc/nagios/objects/templates.cfg'...
Processing object config file '/etc/nagios/objects/localhost.cfg'...
   Read object config files okay...

Running pre-flight check on configuration data...

Checking services...
	Checked 8 services.
Checking hosts...
	Checked 1 hosts.
Checking host groups...
	Checked 1 host groups.
Checking service groups...
	Checked 0 service groups.
Checking contacts...
	Checked 1 contacts.
Checking contact groups...
	Checked 1 contact groups.
Checking service escalations...
	Checked 0 service escalations.
Checking service dependencies...
	Checked 0 service dependencies.
Checking host escalations...
	Checked 0 host escalations.
Checking host dependencies...
	Checked 0 host dependencies.
Checking commands...
	Checked 24 commands.
Checking time periods...
	Checked 5 time periods.
Checking for circular paths between hosts...
Checking for circular host and service dependencies...
Checking global event handlers...
Checking obsessive compulsive processor commands...
Checking misc settings...

Total Warnings: 0
Total Errors:   0

Things look okay - No serious problems were detected during the
pre-flight check

My adjustment of other config files is minimal, essentially just
setting the email address to deliver notifications to.

Yet every time I try to start the service I get this:

# service nagios start
nagios is stopped
Configuration validation failed                            [FAILED]

The error appears to be identical to that reported here:

http://forums.meulie.net/viewtopic.php?f=61&t=6538&start=0

Like the original poster of the thread on that forum, I am able to
start it with "nagios -d /etc/nagios/nagios.cfg" though various web
pages continue to report an unspecified configuration error.

Does anyone have any ideas?


Regards,
Ben

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 259 bytes
Desc: OpenPGP digital signature
Url : http://lists.centos.org/pipermail/centos/attachments/20101106/665b9bb4/attachment.bin 


More information about the CentOS mailing list