[CentOS] yum is dumb in update of gmime & gmime-sharp

ken gebser at mousecar.com
Sun Nov 28 06:31:49 EST 2010


On 11/27/2010 04:38 PM John R Pierce wrote:
> On 11/27/10 12:44 PM, ken wrote:
>> This would seem like a bug... or why is yum trying to install package
>> versions which are already installed?
> 
> this most frequently happens when you mix dependencies of different yum 
> repositories.    I noted .rf in your output, RPM Forge, this has in my 
> experience caused conflicts with EPEL.

John, I agree... that's pretty much when it happens (...not all the time
though).

What I don't understand is why yum can't see simply PACKAGE and VERSION
and see they're the same as what's already installed.  That seems to me
to be a design flaw in yum.




More information about the CentOS mailing list