[CentOS] yum is dumb in update of gmime & gmime-sharp

William Hooper whooperhsd at gmail.com
Sun Nov 28 17:13:00 EST 2010


On Sun, Nov 28, 2010 at 4:00 PM, ken <gebser at mousecar.com> wrote:
>> You need to take a closer look at what yum is trying to install.  This
>> message is telling you yum won't update the package because it will
>> break a dependency on another installed package.
>
> yum's trying to install gmime20.  This doesn't exist on my system.
>
> What dependency would break by installing it?

Looking at the RPMForge spec file for gmime20, it obsoletes any gmime
lower that it's version. You are trying to install gmime20.i386
0:2.2.26-1.el5.rf, which will remove gmime-2.2.10-5.el5.centos.
However, your currently installed gmime-sharp-2.2.10-5.el5.centos
requires gmime-2.2.10-5.el5.centos.  You need to either remove
gmime-sharp-2.2.10-5.el5.centos or find an updated version that will
work with gmime20.i386 0:2.2.26-1.el5.rf.

-- 
William Hooper


More information about the CentOS mailing list